A typical 3D character can be made up of many surfaces and components. To ensure that the character animates in the way that you want, it is important to carefully plan the process of character setup.

Character setup or rigging is the general term used for the preparation of 3D models with their accompanying joints and skeletons for animation.

Depending on the model to be animated, character setup can involve the following techniques:

- Creating a skeleton with joints that acts as a framework for the 3D character model. You set limits on the joints so they rotate in a convincing manner. When you animate the character, you will be posing the character via its joints using either forward or inverse kinematic techniques (FK or IK).

- Binding the 3D surfaces to the skeleton so that they move together. The process of binding may also include defining how the character’s joints bend or how the skin surfaces bulge to simulate muscles.

- Defining and setting constraints for particular animatable attributes in order to restrict the range of motion or to control an attribute based on the movement of another.

- Grouping surface components such as CVs into sets called clusters so that parts of the character (for example, a smiling face or raised eyebrows) can be animated at a more detailed level.
The following lessons show how to use some of the most common character setup features:

- “Lesson 1: Skeletons and kinematics” on page 331
- “Lesson 2: Smooth skinning” on page 349
- “Lesson 3: Cluster and Blend Shape Deformers” on page 362

Preparing for the lessons

To ensure the lessons work as described, select the Animation menu set. Unless otherwise noted, the procedures in this chapter assume the Animation menu set is selected.
Lesson 1  

**Skeletons and kinematics**

After you model the surfaces that make up a human, animal, or other character, you create a skeleton and bind it to the character’s surface (called *skin*).

A skeleton provides a structure for animating the character. When you create a skeleton in Maya, you create a series of bones with joints in the skeletal locations where you want the character to bend or twist. (You can animate a skeleton without having a skinned character.)

In this lesson, you learn the techniques for creating a simple skeleton for a human character. You will learn how to:

- Create joints for a character.
- Name joints in the Hypergraph.
- Use symmetry when creating a character.
- Parent joints into an existing skeleton.
- Use Inverse Kinematics (IK) techniques to pose a skeleton.

Learning how to bind a character to a skeleton is described in the next lesson.

**Open the scene for the lesson**

In this lesson, you’ll work with a scene that we created for your use. The scene contains a human character. In the remainder of the lesson, you’ll create and animate a skeleton for the character.

**To open the scene**

1. Make sure you’ve done the steps in “Preparing for the lessons” on page 330.
Open the scene named **Skeletons.mb**.

You can open the scene named **Skeletons.mb** from the *Maya Documentation, Lessons, and Extras* CD or from the drive where you copied the Getting Started with Maya data files.

The character displayed in the scene, jackie, is a template, so you cannot unintentionally select it during the lesson. Jackie was modeled in the Da Vinci pose, the position that’s easiest for creating a skeleton.

**Creating joints**

A skeleton is made of bones and joints. When you create a skeleton in Maya, you create a series of joints in the skeletal locations where you want the character to bend or twist.

A common technique for creating a skeleton is to create several independent joint chains—one for each arm, one for each leg, one for the spine/head—then group the chains together to create a single skeletal hierarchy. In the steps that follow, you create the joints for the legs.

**To create joints for the legs**

1. Select Window > Settings/Preferences > Preferences. In the Preferences window, click the Kinematics Category. Enter 0.4 for the Joint Size, then click the Save button.

   This displays the joints smaller when you create them in the next steps. At the default size, 1.0, the size of the joints makes them hard to position accurately for this character.

2. Select Skeleton > Joint Tool. This is the tool for creating the joint chains that make up a skeleton.
3 In a side view, click at the hip, knee, ankle, ball of foot, and toe to create joints at these positions (see the following figure). Make sure the knee joint is in a position that creates a slight forward bend. The forward bend ensures that you will be able to animate the leg easily in a direction natural for a leg.

4 Press Enter (Windows, IRIX, and Linux) or Return (Mac OS X) after creating the toe joint. This completes the joint chain.

5 Select Window > Hypergraph. The Hypergraph is a convenient place to select, rename, and parent objects. It is similar to the Outliner, but it has features tailored for character setup. For example, it depicts all parent-child relationships in an easy-to-read indented format.

The Hypergraph shows the default names given to the joints just created: joint1, joint2, and so on. The joints have a hierarchical relationship. Joint1 is the parent of joint2, which is the parent of joint3, and so on. Joint1 is the root of the hierarchy. If you reposition joint1, you reposition the whole joint chain.

In the scene view, joints are represented by spherical icons. Bones separate the joints, and are represented by elongated pyramid icons. The narrow part of a bone points in the downward direction of the hierarchy.
The reason you create the hip joint first and the toe joint last is to have the hip at the top of the hierarchy and the toe at the bottom. You’ll usually want the toe (and other joints) to move whenever you move the hip, but not necessarily vice versa. In general, joint chains emanate from the interior of the character outward.

6 Rename the joints as left_hip, left_knee, left_ankle, left_ball, and left_toe. To rename a joint, Ctrl right-click (Windows, IRIX, and Linux) the joint name in the Hypergraph and select Rename from the drop down menu. Enter the new name and press Enter.

7 In the front view, click the left_hip joint to select it. Move it along the X-axis to the center of the top of the left leg. (In this lesson, left and right refer to directions from jackie’s point of view, not from your view of the scene.)

As mentioned before, when you move a joint, all joints lower in the hierarchy move with it. If you press Insert (Windows, IRIX, and Linux) or Home (Mac OS X) while a joint is selected, you can move the joint without moving joints below it in the hierarchy. (To exit this mode, press Insert or Home again.)

8 Rotate left_hip so that the skeleton fits inside the leg. It’s unnecessary to fit the skeleton perfectly inside the character, as it won’t be displayed when you render an image from the scene.

9 To create the joints for the other leg, you can save time and ensure symmetry by duplicating the existing leg joint chain with mirroring. With left_hip selected, select Skeleton > Mirror Joint > □. In the options window, turn on YZ for Mirror Across.
Jackie’s legs straddle the YZ plane, so mirroring the joint chain across the YZ plane positions the duplicate joint chain in the desired location. This operation illustrates that Jackie’s original position affects the ease with which you can create the skeleton. Had Jackie been positioned away from the origin, you would not have been able to use Mirror Joint conveniently to duplicate the leg’s joint chain.

10 Enter left in the Search For field and enter right in the Replace With field.

The Replacement Names for Duplicate joints feature automatically replaces the names of all duplicate joints with the specified joint prefix.

11 Click the Mirror button.

The right leg bones and joints appear in a mirrored position.

In the next steps, you create a joint chain for the spinal column. You also extend a joint from the upper neck region of the joint chain so that you can animate the jaw.
To create joints for the spine and jaw

1. In the side view, use the Joint Tool to create a series of joints at the locations shown in the figure. Start at the base of the spine near the existing hip joints and end at the top of the head. Make sure you create the first joint a little bit away from the existing hip joint displayed in the front view. Otherwise the first joint will be connected to the hip joint. Remember to press Enter (Windows, IRIX, and Linux) or Return (Mac OS X) when you are done creating the joint chain.

   With the exception of the joints at each end of the joint chain, the joints are located where the character is likely to bend or twist at the spine and neck.

   The S-shaped curvature of the joint chain resembles Jackie’s spinal curvature. This makes it easier to animate the character’s torso and neck naturally.

2. From bottom to top, name the joints back_root, pelvis, lower_back, mid_back, upper_back, lower_neck, upper_neck, crown.

3. To set up the skeleton for jaw movement, extend a joint from the upper_neck joint. With the Joint Tool selected, click the upper_neck joint to select it then, click to create a new joint near the lips, and press Enter or Return. Name the new joint as jaw.
Creating joints for the arms is similar to creating joints for the legs.

**To create joints for the arms**

1. In the front view, create a series of joints at the locations shown in the figure. Start at the pectoral region (near the upper_back joint) and end at the wrist.

2. Name the joints left_arm_root, left_shoulder, left_elbow, and left_wrist.

3. In the top view, select the left_elbow joint, select the Move tool, press Insert (Windows, IRIX, and Linux) or Home (Mac OS X), then move the joint to the back of the arm. Press Insert or Home again.
Moving the joint to the back of the arm creates a bend at the elbow. This will make it easier to animate the character’s arm in the direction an arm naturally bends.

4. In the perspective view, select left_arm_root. Select Skeleton > Mirror Joint. This creates a copy of the left arm’s joint chain for the right arm and renames them in the process. The right arm bones and joints appear in a mirrored position.
Adding joints to a skeleton

When you bind a character to a skeleton (described in the next lesson), the skeleton provides a structure for the character’s skin and prevents the skin from collapsing as you pose the skeleton.

It’s useful to add extra joints in areas of the character where you want the surface to keep its volume upon deformation. In the next steps, you’ll add ribs to jackie’s skeleton. Although you will not bind the character in this lesson, the technique of adding ribs is important to learn so that when you do bind a character, the skin in the torso area will not collapse as you pose shoulder and spinal rotations. The rib joints are for structure only, not for posing the skeleton.

To add ribs to the skeleton

1 In the Hypergraph, click the mid_back joint to highlight the joint in the front view. Remember the location of the joint in the front view so you can select it later (step 3).
2 Select Skeleton > Joint Tool.
3 In the front view, click on the mid_back joint to select it again.
4 Click to the side of the joint to add a rib bone, then press Enter (Windows, IRIX, and Linux) or Return (Mac OS X).
5 With the same technique as in the prior steps, create two more ribs for the left side. The ribs extend from the mid_back, lower_back, and pelvis joints.

6 For easy identification in the Hypergraph, you can optionally name the ribs as desired. For instance, name them left_top_rib, left_mid_rib, left_bottom_rib, and so on.

7 Mirror the left rib joints to create ribs for the right side of the skeleton.

**Creating a skeleton hierarchy**

So far you have created five separate joint chains: one for the spine, and one for each arm and each leg. You need to create a single hierarchy from the five joint chains so you can move all of them as a single unit. To create the single hierarchy, you parent the arms and legs to the nearest joint in the spine.

**To parent the arm and leg joint chains to the spine**

1 In the Hypergraph, use the middle mouse button to drag left_arm_root to upper_back.

   When you parent one joint to another, Maya creates a bone that connects the parent to the child. In this case, the bone connects upper_back to left_arm_root.
2 Use the middle mouse button to drag right_arm_root to upper_back.

3 Use the middle mouse button to drag left_hip to back_root.

4 Use the middle mouse button to drag right_hip to back_root.

Now if you need to move the entire skeleton, you can move back_root—the root of the hierarchy. The completed skeleton is shown in the following figure (with jackie hidden):

**Forward and Inverse Kinematics**

There are two techniques for posing a skeleton: forward kinematics and inverse kinematics.

**Forward Kinematics (FK)**

To pose a character with forward kinematics, you rotate each joint individually until you get the desired positioning. For example, to move a hand to some location, you must rotate several arm joints to reach the location.

When you animate a skeleton posed with forward kinematics, Maya interpolates the joint rotations starting with the root joint, then the root’s child joints, and so on down through the skeleton’s action hierarchy. Maya proceeds forward through the action hierarchy, starting at the root joint.

Forward kinematics is intuitive for creating simple arc motions, but it’s tedious if you are animating a complex skeleton. It’s also not intuitive for specifying goal-directed motion. For example, to move a hand to some location, it’s not obvious how to rotate the joints in an arm.
Inverse Kinematics (IK)

With IK, you create an extra control structure, an IK handle, for certain joint chains such as arms and legs. An IK handle lets you pose and animate an entire joint chain by moving a single manipulator.

As you pose the IK handle, it automatically rotates all the joints in the joint chain. For example, if you move a hand to a doorknob, the other joints in the arm rotate to accommodate the hand’s new positioning.

IK is more intuitive than forward kinematics for goal-directed motion because you can focus on the goal rather than on how you need to rotate each joint to achieve that goal.

Posing and animating using inverse kinematics

Next, you create IK handles that you’ll later use to pose the arms and legs. The next steps describe some initial setup you should perform before creating the IK handles.

To set up the character prior to creating IK handles

1. Select the root of the hierarchy, back_root, and then select Skeleton > Set Preferred Angle.

   This sets the current joint angles throughout the skeleton as the preferred angles. This is a useful step after you complete a skeleton. Maya thereafter uses the current bend in the knees and elbows as the preferred initial rotation direction of these joints during inverse kinematics (IK) posing. This makes it easier to pose the character with motion that is natural for a human character.
2 Select jackie in the Outliner and select Display > Hide > Hide Selection. (You must select and hide jackie from the Outliner because jackie is a template object.) By hiding jackie, you’ll lessen scene clutter as you pose the skeleton in the following steps.

To create, pose, and animate IK handles for the legs
1 Select Skeleton > IK Handle Tool > ikRPsolver.
2 In the Tool Settings window, make sure Current Solver is set to ikRPsolver.
   This type of IK solver has characteristics that work well for this application.
3 In the perspective view, click left_hip and left_ankle.
   This creates an IK handle that lets you control all joints from left_hip through left_ankle. The handle’s main manipulator is at the left_ankle.
   The IK handle is the selected object after you create it. If you unintentionally cancel the selection of the handle, you can select it again by clicking the left_ankle—the last joint you clicked after using the IK Handle Tool. Whenever you select a handle, make sure you do not select joints or other objects along with the handle. You can check the Outliner to confirm your selection.
4 Go to the start of the playback range.
5 With the IK handle selected, select Animate > Set Key to key the leg’s current position at the first frame.
6 Go to frame 12.
In the side view, use the Move tool to drag the IK handle up and to the left (see illustration), as if jackie were stepping up a staircase. The foot and knee move while the hip stays in place.

Set another key for the IK handle.

Go to frame 24. Move the IK handle back to its prior position. Set another key.

Play the animation to see the leg step up and down during the first 24 frames.

This completes a simple animation of the leg using an IK handle to control its position.

To practice additional IK techniques

Go the start of the animation.

In a perspective view, practice posing the leg in various directions by moving the IK handle.

No matter how far you drag the handle manipulator, the joints of the leg will not stretch beyond the straight leg position. This is desirable; you do not want the size of a skeleton to change as you pose it. However, if you drag a leg joint, the bone hierarchically above that joint will lengthen. This is why it’s important to check that you haven’t selected a joint with the IK handle before you move the handle.

As you drag the handle to some positions, you might notice the leg joints flip abruptly (see the next figure for an example position). It’s therefore hard to control the leg positioning in this region.
The default IK handle (*IK Rotate Plane handle*) has manipulators you can use to avoid joint flipping. With the handle selected, select Modify > Transformation Tools > Show Manipulator Tool. Move the Pole Vector XYZ manipulator to a slightly different position (see the following figure).

If this doesn’t solve the problem, rotate the Twist manipulator to rotate the leg. You can key the Pole Vector XYZ and Twist attributes to fixed values to avoid the flipping as the character moves.

A more precise way to avoid joint flipping, which requires some initial setup, is to use a Pole Vector Constraint. For more information see the Maya Help.
3 Repeat the preceding steps for the right leg. (Create an IK handle for the right_hip to right_ankle, then practice posing and animating the handle.)

| Note | If you want to move the entire skeleton, group the back_root and all IK handles under a single node, select the group node, and then use the Move tool. With this grouping, the motion of the entire skeleton won’t conflict with the keys you set for the handles. |

**To create, pose, and animate IK handles for the arms**

1 Select Skeleton > IK Handle Tool.
2 Click left_shoulder, and then click left_wrist. This creates an IK handle for the left arm.
3 Select Skeleton > IK Handle Tool.
4 Click right_shoulder, then click right_wrist. This creates an IK handle for the right arm.
5 Practice posing and animating the handles.

**Posing and animating using forward kinematics**

As the last part of the lesson, you can optionally practice posing and animating the character by rotating joints that are not controlled by IK handles—the ball joints of the feet, and joints from the back_root through the upper_neck. Rotating such joints is forward kinematics.

With the exception of the back_root, you’ll invariably rotate rather than move the joints that aren’t part of an IK handle. If you move the joints, the bones lengthen. This deforms bound skin undesirably unless you are creating cartoon-like distortions.
Because you’ve already set keys for IK handles, some joint rotations on non-IK handle joints will be restrained by the IK handle positioning. If this interferes with the intended poses, you can remove all prior animation from an IK handle by selecting Edit > Keys > Delete Keys. You can also use Delete Keys to remove all animation from keys you’ve set with forward kinematics.

**Beyond the lesson**

In this lesson you learned how to:

- Create a skeleton with bones and joints.
- Pose the skeleton using Inverse Kinematics.

Additional things to consider when working with skeletons:

- The appropriate number of joints in a skeleton depends on the anatomical parts of the character you want to manipulate. More joints means finer control at the expense of greater complexity.
- As you created the skeleton in this lesson, you ended the arm’s joint chain at the wrist. This prevents you from animating hand motion. If you need to animate hand motion or even finger motion, you would need to make additional joints and IK handles. The same applies to foot and toe motion.
- When you create a skeleton, you can animate a character bound to it to produce natural skin deformations. Although you animated an unskinned skeleton in this lesson, it’s more common to animate a skinned skeleton. Binding a character is the topic of the next lesson.
- It’s typically best to animate the entire skeleton from pose to pose at desired frames. It’s hard to get desired results by animating one limb for a frame range, another limb for a frame range, and so on.
There are many other ways to work with skeletons not described in this lesson:

- You can blend or switch between IK and forward kinematics on joints controlled by an IK handle.
- There are other types of IK handles that provide different controls for manipulating parts of a skeleton. Especially noteworthy is the IK spline handle, which makes it easy to animate the twisting, wavy motion in tails, necks, spines, snakes, and so on.

For more details on these and other features, please refer to the Maya Help.
Lesson 2  Smooth skinning

After you create a skeleton, you bind it with the character’s surface so that the surfaces move with the skeleton during animation. Binding is also called skinning, and a character’s surface after binding is called a skin.

It is important that the character’s skin deforms naturally as the skeleton moves. Near joints, the skin bulges or indents when you rotate the joints.

In Maya, the skin deforms because the surface’s vertices (or CVs) move in response to the rotation of adjacent joints. The vertices are known as skin points. This is useful for animating elbows, shoulders, necks, and so on.

By default, the influence a joint has on a skin point’s movement depends on how close it is to that joint. You can edit skin point weighting to change the default movement.

In this lesson you learn how to:

• Bind a skeleton using a smooth bind technique.
• View and modify skin weights using the Skin Weights Tool.
• Use influence objects to enhance the skin deformation of a character.
Open the scene for the lesson

In this lesson, you work with a scene we created for your use. The scene contains a human character and skeleton. Each leg and arm of the skeleton has an IK handle that lets you pose the limbs conveniently. If you completed the prior lesson, the character, skeleton, and IK handles will be familiar.

1. Make sure you’ve done the steps in “Preparing for the lessons” on page 330.

   You can open the scene named SmoothSkin.mb from the Maya Documentation, Lessons, and Extras CD or from the drive where you copied the Getting Started with Maya data files.

   The character in the scene, jackie, is displayed with transparency so you can see the skeleton beneath the surface.

2. Select Window > Settings/Preferences > Preferences. In the Preferences window, click the Kinematics Category. Enter 0.4 for the Joint Size, then click the Save button.

   This displays the joints smaller. At the default size, 1.0, the large size of the joints obstructs the view of the skin.

Smooth binding a skeleton

You use jackie as the surface to be bound to the skeleton.

To bind the skeleton using smooth skinning

1. Select jackie.
2. Shift-select the back_root joint.
The back_root joint is at the base of jackie’s spine. If you are not sure which joint it is, select it in the Hypergraph (Window > Hypergraph).

3 Select Skin > Bind Skin > Smooth Bind > \(\square\). Set Max Influences to 3, then click Bind Skin.

A Max Influences value of 3 specifies that three joints influence each skin point. By default, the joint closest to the point has the most influence. The second most influential joint is that joint’s parent or child joint, whichever is closest to the point. The third most influential joint is the nearest parent or child of the second joint. The influence drops with the distance from the joints. The amount of influence each joint has on any skin point is the skin weight.

The default skin weights create smooth deformations of the skin at elbows, knees, and elsewhere as the nearby joints rotate.

4 Select and move any or all of the four IK handles to pose the arms and legs in various positions in order to get used to posing with the IK handles.

To select an IK handle, drag a selection box around a wrist or ankle joint. To move a handle, use the Move tool to drag the handle in the desired direction.

Note that you can also select the IK handles in the Hypergraph. The handles are indented under jackieSkeleton. Each is named for a leg or arm, for example, ikHandleLeftLeg. For more details on IK handles, see “Lesson 1: Skeletons and kinematics” on page 331.

5 If you prefer to turn off the skin’s transparency so you can see the skin more clearly, turn off Shading > Shade Options > X-Ray. Do not be concerned that the skeleton pokes through the skin, as the skeleton is not displayed in a rendered image.
As you pose the arms and legs, examine the skin in the regions where joints bend. For many poses, the skin looks natural. For others, the skin folds, compresses, or bulges unnaturally. The pelvis, shoulders, and torso are common problem areas for various poses. For example, if you move an arm straight up, the shoulder compresses as in the following figure.

There are two ways to improve the smooth skin deformations:

- Add an influence object to eliminate collapsing regions or to create muscle bulge. For example, you can use an influence object to make the shoulder region look more natural in the prior pose.
- Edit skin weights—to remove minor lumps or indented regions. For example, you can fill out an undesirable concave region at the chest that appears when you move the arm to certain poses.

The following procedures explain the techniques.

**Skin weighting and deformations**

In the next steps, you’ll learn how joints and skin weights influence deformations at jackie’s chest. In a subsequent section, you’ll improve uneven deformations.
To see how skin weights affect a skin’s deformation

1. Pose the left arm similar to the following figure. The left breast becomes irregularly shaped.

![Breast collapses in this pose](image)

2. Select jackie.

3. Select Skin > Edit Smooth Skin > Paint Skin Weights Tool >.

4. In the Influence list of the Tool Settings window, select any joint, for instance, pelvis. The grayscale color of jackie’s skin indicates how much influence that joint has on the skin’s deformation.

   White means the skin is maximally influenced by the joint.
   Black means the skin is not influenced by the joint. Gray means the influence is partial. The lighter the gray, the more the influence.

   Each point on the surface is influenced by three joints, as specified by the Max Influence setting in a prior step. However, one or two of the three joints might have so little influence as to be insignificant.
In general, a white region of skin is influenced nearly entirely by the joint selected in the Influence section of the Tool Settings window. A gray region is influenced significantly by one or two additional joints.

5 The reason the left breast becomes irregularly shaped as you pose the arm is that some joint is exerting too much or to little influence on the breast.

6 Select each entry in the Influence list to determine which joints are influencing the irregular region of the breast. The region will be a shade of gray (or white) when you select the appropriate joints. The left_arm_root is the main influence. The upper_back, mid_back, and left_top_rib also have influence, though not exactly in the same region.

**Modifying skin weights**

You can modify the skin weights for any of the influencing joints to alter the irregular region. If you don’t get the desired results when you change the skin weights of one of the influencing joints, you can undo your changes and try another influencing joint.

In general, it’s best to modify the skin weights of the most influential joint first, then work with less influential joints if you don’t get the desired results. Modifying skin weights requires experimentation.

In the next steps, you’ll modify the skin weights for the left_arm_root joint.

**To modify skin weights using the Paint Skin Weights Tool**

1. Select left_arm_root in the Influence list.
2. In the Paint Weight Menu section of the window, set Value to 0.1 and turn on Add.
3 Drag the mouse pointer to paint the irregular region of the breast. Each stroke adds 0.1 (10%) to the skin weight. The weight for a skin point has a maximum value of 1 (fully white).

**Tip**

Painting skin weights using a tablet with stylus allows you to take advantage of pressure sensitivity.

Repeat the strokes several times until the irregular region becomes smoother. The jagged, asymmetrical wireframe at the breast becomes more symmetrical as the skin becomes smoother. The region whitens, which indicates increased influence from the left_arm_root joint. Note that increasing the influence of one joint lessens the influence of the other influencing joints.

4 To check the shape with full-color shading, click the Select Tool. (You might also prefer to cancel the selection of jackie to eliminate the display of the highlighted wireframe.)

5 To continue modifying the skin weights with the Paint Skin Weights Tool, select jackie and once again select Skin > Edit Smooth Skin > Paint Skin Weights Tool.
There are several additional tool settings you might find useful as you modify skin weights:

- The Smooth operation smooths the weights of points by averaging the stroked points with the weights of the surrounding region. This is useful if you add to the weight values in some region but the points become unevenly weighted. Uneven weights are indicated by mottled gray skin.

- You can use the Scale operation with a Value less than 1 to scale down the point weights of a stroked region.

- As you stroke a region, the red circle icon displays the radius of the region affected by the stroke. The Radius(U) value changes the radius.

- You can select any of the Profile icons to specify the region affected by strokes. The two leftmost icons are the most commonly used shapes.

6 After you eliminate the irregular region from the left breast, move the arm to different positions to see if the breast’s shape stays natural in various poses. It is common for a surface to look good in one pose but not in another. Strive to make the surface look good in the poses that you are likely to use during animation.

7 If you want more practice, pose the right arm as you posed the left arm and fix the corresponding irregular region in the right breast. This time, fix the region by modifying the weights for the upper_back joint rather than the right_arm_root. As mentioned previously, you can modify point weights of alternative joints to get a similar effect.

**Influence objects**

You can create an object and use it to influence the shape of smooth skin. The object, called an influence object, acts like a surgical implant against which the skin deforms. For example, you can create a sphere and use it to simulate a muscle or bone
that bulges as you pose the character in certain positions. You can also use an influence object to smooth deformation and maintain volume in regions that collapse while bending.

In the next steps, you’ll use a sphere as an influence object to simulate an elbow jutting out as jackie’s arm bends. To use an influence object, the skeleton must be in the bind pose—the original pose at which the skin was bound to jackie.

To return the skeleton to the bind pose

1. Click the Select Tool and cancel the selection of jackie.
2. Turn off Modify > Evaluate Nodes > IK Solvers.
   - After you use an IK handle to pose a character, you must do this step before you can return the skeleton to the bind pose.
3. Select back_root, the root of the skeleton.
4. Select Skin > Go to Bind Pose.
5. Select the ikHandleLeftArm in the Hypergraph. Use the Move Tool to move the handle manipulator slightly in any direction. When you release the mouse, note that the arm does not move and that the IK handle manipulator snaps back to the desired position at the end of the joint chain. Repeat this step for any other IK handles you posed previously.
6. Turn on Modify > Evaluate Nodes > IK Solvers.
You must do this step to enable the IK solvers so you can manipulate IK handles in the scene again.

**To position a sphere to be used as an influence object**

1. Right-click jackie’s surface (anywhere but on the skeleton) and select Actions > Template from the marking menu.
   By making jackie a template, you won’t accidentally select jackie in subsequent steps.

2. Select Create > Polygon Primitives > Sphere, and name the sphere `elbow_influence`.

3. Scale the sphere to be slightly smaller than any of jackie’s joints (see illustration below).

4. Move the sphere so that its surface is positioned where the elbow would jut out, but still within the skin. You can optionally reshape the sphere’s curvature to resemble the tip of an elbow jutting out from a bent arm. For example, you can scale the sphere in one dimension to squash its shape or you can move individual vertices. A top view of the sphere’s shape and position follows:

   ![sphere (elbow_influence)](image)

   The exact position and scale of the sphere is unimportant. You can make slight position and scale adjustments later to enhance the deformations that result from its use.

**To make the sphere an influence object**

1. In the Hypergraph, select jackie and Shift-select `elbow_influence`.

Getting Started with Maya
358
2 Select Skin > Edit Smooth Skin > Add Influence > □. In the Add Influence Options, select Edit > Reset Settings, and then click the Add button.

Maya completes the operation within a few moments. To ensure the influence object stays in the correct position at the elbow, you will parent it to the left_shoulder joint.

3 In the Hypergraph, shift-select elbow_influence, elbow_influenceBase, and left_shoulder joint, in that order.

The order of selection is important. The parent object should be selected last.

4 Press p to parent the elbow nodes under the left_shoulder joint.

The elbow_influence nodes appear in the skeleton hierarchy below the left_shoulder joint.

The elbow_influenceBase is known as a base object. It stores vertex position information for the influence object. The reason for parenting the base object to the left_shoulder joint is so that the influence object’s vertices stay in the correct position at the elbow whenever the elbow moves to a new position. Other than this step, you do not work with the base object.

5 Right-click jackie and select Actions > Untemplate. It is easier to see subsequent skin deformations when jackie is displayed with smooth shading rather than as a template.

6 From the menus at the top of the top view, turn off Show > Joints to avoid having the joints obstruct your view of the skin.

7 Use each arm’s IK handle (ikHandle1 and ikHandle2) to pose the arms in the following position.
The left elbow looks more natural than the right elbow. To tune the elbow’s deformation during bending, change the position, scale, and rotation of elbow_influence.

Do not be concerned if the influence object pokes through the skin. It won’t be displayed when you render the animation.

**Beyond the lesson**

In this lesson you learned how to:

- Bind a skeleton to a single surface.
  
  You can bind a skeleton to multiple surfaces or even to a selection of polygonal vertices or NURBS CVs or subdivision surfaces.

- Use the Paint Skin Weights Tool to prevent a region from collapsing upon deformation.
  
  To control skin weights with more precision than shown in the lesson, you can modify skin weights numerically with the General Editors > Component Editor. If you smooth skin multiple surfaces which have been seamed together, there are many tool settings for the Paint Skin Weights Tool that make the task easier.

- Use an influence object to make an elbow stick out upon bending.
Another common use of an influence object is to simulate a muscle bulging during joint rotation. The technique requires use of Set Driven Key to link the bulging influence object’s scale values to the rotation of the appropriate joint. A brief example of this technique is in the Maya Help for Smooth Skin.

Skin weights and influence objects cannot overcome all modeling problems. For instance, if you further separate Jackie’s legs sideways, you will see an unsightly fold at the hips. This occurs because of the asymmetrical arrangement of polygonal edges in the hip region of the original model. To fix the problem, you would need to detach the skin, alter the original model, then smooth bind the model again.

Maya has an alternative skinning method, rigid skinning, which gives results similar to smooth skinning but requires use of different enhancement tools: flexor and lattice deformers. In general, smooth skinning gives more natural deformations with less effort than rigid skinning. If you skin multiple seamed surfaces, however, processing is faster with rigid skinning than with smooth skinning.

Smooth skinning is just one of the techniques for perfecting a character’s deformations during animation. You can use Maya’s other deformers alone or in addition to smooth skinning to achieve the results you want.

For more information, please refer to Smooth skinning in the Maya Help.
Lesson 3  **Cluster and Blend Shape Deformers**

Facial animation is an integral component of character animation. The face of a character can be animated to impart a range of emotions and expressions. Maya has two deformation tools that ease character setup for facial animation: cluster deformers and blend shape.

Cluster deformers enable you to control a set of an object's points (CVs, vertices, or lattice points) with varying amounts of influence to create a target shape for an animation.

A Blend Shape deformer provides an interface for blending between various target shapes, to control the range of movement for the cluster on an object or face.

In this lesson, you will be introduced to cluster deformers in order to shape a character’s mouth into a smile pose. You will learn to use the Blend Shape feature so you can animate the face from a neutral pose to a smile. In this lesson, you learn how to:

- Select CVs in a region and create a cluster deformer.
- Use the cluster deformer handle to adjust the position of a cluster deformer.
- Use the Paint Cluster Weights Tool to refine the cluster weight values.
- Create a Blend Shape deformer to control the blending between target shapes.

**Open the scene for the lesson**

In this lesson, you’ll work with a scene we created for your use.

1. Make sure you’ve done the steps in “Preparing for the lessons” on page 330.
2 Open the scene named ClusterBS.mb.
   You can open the scene named ClusterBS.mb from the Maya Documentation, Lessons, and Extras CD or from the drive where you copied the Getting Started with Maya data files.
   The scene contains a man’s head.

3 Select Shading > Smooth Shade All and then Shading > Hardware Texturing, and Lighting > Use All Lights to view the head fully textured. (Hotkey: 7)

Creating a target object for a blend shape

In the next steps, you duplicate the face of the head to create a target object for the blend shape. Later in the lesson, you apply a cluster to the duplicated face (target object) so you can create a smile. The facial expression on the target object is what the original base object will match.

1 Using the Outliner, select the only face, which is the head without the eyes, ears, and hair.
   In the Outliner, the face is named baseFace and is indented under head.
Lesson 3 > Creating a cluster deformer on a target object

2 Select Edit > Duplicate > ![Image](image.png). In the options window, select Edit > Reset Settings, turn on World for the Group Under option, then click the Duplicate button. By grouping the duplicate under the world, you create an object independent of the original.

3 Move the duplicate face to a position where both faces are visible for comparison, for instance, to the right side of head.

4 Rename the duplicate face as smilingFace. This duplicate face will be modified so it can be used to influence the original.

Creating a cluster deformer on a target object

In the next steps, you create a cluster deformer on the duplicated face (target object) to reshape the expression into a smile. The cluster deformer on the target object will be used to change the unsmiling baseFace (base object) into a smiling face.

A cluster deformer creates a set whose members consist of selected points (CVs, vertices, or lattice points). You assign a percentage weight to each point, indicating how much you want each point to be affected by any translation, rotation, or scale of...
the cluster set. When you transform the cluster, the points are transformed according to the percentages you have specified. A cluster is useful for stretching, moving, or compressing part or all of a surface.

**To create a cluster deformer**

1. Position the mouse pointer over the face. Right-click to select Vertex, then select the smilingFace vertices shown in the following illustration, which are roughly the vertices at the chin, cheeks, and lips (but not the nose):

   ![Side view and Persp view](image)

   The region of selected vertices does not need to be exact. The objective is to select all vertices where a smile might deform the face. You might want to look in a mirror to see which parts of a face move while smiling. It’s better to select too many vertices than too few. It’s easier to work with too many vertices than too few.

   An easy way to select the vertices is to use the Paint Selection Tool. First, right-click smilingFace in the scene view and select Vertex from the marking menu. Select Edit > Paint Selection Tool > □. In the resulting options window, set Radius(U) to
0.2. Drag the mouse on the desired vertices. Ctrl-drag (Windows, IRIX, and Linux) or Control-drag (Mac OS X) to cancel the selection of inadvertently selected vertices. Close the Tool Settings window when you are done.

Make sure you don’t select vertices at the back of the head inadvertently. Also make sure you don’t inadvertently miss a few vertices in the region you select.

2 Select Deform > Create Cluster.

This puts the vertices into a cluster—a set of points you can move as single entity. The cluster’s handle appears in the view as a C icon.

3 In the Outliner, make sure the cluster2Handle is selected.

4 Use the Move tool to drag the cluster handle up along its Y-axis a small amount until smilingFace is deformed as follows:

The cluster set on smilingFace should be slightly higher than the math on the original face. This will become the basis for the blend shape deformer.
Editing cluster weights

In this section you will use the Paint Cluster Weights Tool to further refine the smilingFace. As you saw in previous steps, the points in a cluster move when you move the cluster handle. The distance a particular point moves depends on its weight. Lower weights cause less movement, while higher weights cause exaggerated movement. In the next steps, you create a smile by editing the weights.

To edit cluster weights using the Paint Cluster Weights Tool

1. Select smilingFace.
2. Select Deform > Paint Cluster Weights Tool > boxshadowup. This displays the smilingFace in grayscale.

The white area shows the points that make up the cluster. The whiteness also indicates the weights—how much the points move in response to the movement of the cluster handle. White indicates a cluster weight of 1—the points move the same distance as the handle. By default, each point has a weight of 1.
Black indicates a cluster weight of 0. The points do not move in response to cluster handle movement. Note that regions that are not part of the cluster are also black.

Although there are no gray regions currently, gray means the movement is partial. The lighter the gray, the more the movement. Gray regions indicate a cluster weight between 0 and 1.

3 In the Paint Attribute Section of the Tool Settings window, set the following:
   • Value: 0.5
   • Replace Operation: On

4 Click the Flood button.
   This gives all the cluster points a weight of 0.5. The white region is now gray:

   The selected vertices move down a bit, as the weight of 0.5 lessens the effect of the prior movement of the cluster by 50%.

5 To check the shape with full-color shading, click the Select Tool. (You might also prefer to cancel the selection of smilingFace to eliminate the display of the highlighted wireframe.)
6 To return to the Paint Cluster Weights Tool, select smilingFace and Deform > Paint Cluster Weights Tool > Edit again.

7 In the Tool Settings window, make these settings:
   - Radius(U): 0.1
   - Value: 1
   - Opacity: 0.3
   - Operation: Replace

   The settings have this effect when painting:
   - A Radius(U) of 0.1 sets the radius of the region affected by the stroke. The red circle icon on the face displays the radius.
   - A Value of 1 sets the weight value you paint on the points.
   - An Opacity of 0.3 scales down the effect of painting weight values so you can build up values gradually with repeated strokes.
   - A Replace Operation paints the Value specified on the points stroked.

8 Paint the region at the corners of the mouth with repeated strokes until the face looks roughly like the following figure. If your results differ from the figure significantly, undo the strokes and try again.
While painting weights, it’s useful to intermittently check the shape with full-color shading rather than with the grayscale shading. To do this, click the Select Tool to turn off the Paint Cluster Weights Tool. (You might also prefer to cancel the selection of smilingFace to eliminate the display of the highlighted wireframe.)

9 Enter a Value of 0.25 and paint the central region above and below the lips as follows:

Because the corners of the mouth have a high weight and the central region around the lips have a low weight, the corners move up more in response to the prior positioning of the cluster handle. This creates a smiling mouth. The cheeks and chin have a medium weight, so they also move up slightly also. (For many people, skin at the chin and neck moves during smiling.)

10 In the Tool Settings window of the Paint Cluster Weights Tool, turn on the Smooth operation. Then paint any region where the surface has become irregular. Irregular regions are typically indicated by jagged wireframe curves (isoparms) or where a grayscale color makes an abrupt change to a lighter

---

7 | Character Setup
Lesson 3 > Editing cluster weights

Getting Started with Maya
370
or darker color. Smoothing averages the weights of the stroked points with the weights of the surrounding region. The Value setting has no effect on smoothing.

11 Replace and smooth weights in other regions of the face until you are satisfied with the smile. For example, you might want to reduce the weight values at the side of the nose and immediately below the nose.

Your smilingFace should now have a slight smile as a result of your cluster weight edits.

12 Hide the Paint Attributes Tool settings window.

Creating a blend shape

In this section, you create a blend shape deformer to control the smile on baseFace (base object) using the smilingFace (target object). A blend shape deformer is ideal for facial animation, where you need a number of facial positions to be readily available for use in an animation sequence. With a blend shape deformer, you can set up a character’s face to blend between a smile, frown, smirk, and so on.

In the next steps, you create a blend shape deformer to change the baseFace into the smile of smilingFace.

To create a blend shape deformer

1 In the Outliner, select smilingFace and ctrl-select baseFace, specifically in this order.

   The smilingFace (the first selection) is called the target object, while baseFace (the second selection) is called the base object. The objective of a blend shape operation is to morph the base shape into the target shape.

2 Select Deform > Create Blend Shape > /boxshadowup.

3 In the Blend Shape node text box, type blendShape, then click Create.
4 Select Window > Animation Editors > Blend Shape. This displays the Blend Shape editor, which has a slider for changing the base into the target shape, and buttons for setting keys.

5 Cancel the selection of the faces so you can see the surfaces without the obscuring highlighted wireframe.

6 Drag the slider from 0 to 1 to morph the baseFace into the target, smilingFace.

Note that you can click the Key button below the slider to set an animation key for the shape of the face at the current frame. By setting a few keys with different slider values at different points in the timeline, you can animate from the neutral expression to a full or partial smile or vice versa.

When you key the shape, Maya applies the key to the blendShape node that was created when you selected Window > Animation Editors > Blend Shape. If you need to select the blendShape node, for instance, so you can see or delete the keys in the Time Slider, click the Select button in the Blend Shape editor.

**Refining deformation effects**

The combination of a cluster and blend shape is ideal for facial animation because it lets you tune various subtle deformations. A few common techniques follow.
In the box below the slider of the Blend Shape editor, you can enter a numerical value below 0 to invert the deformations, or above 1 to amplify the deformations. For example, -1 creates a frown, while 1.6 creates a brimming smile:

- With or without changing the Blend Shape slider, you can move, rotate, and scale the cluster handle to modify the blend shape. The following figure shows some examples. The face you created will be slightly different because your original smile is different.

- You can use the Paint Cluster Weights tool again to change cluster weights when the cluster and blend shape editing deforms certain regions undesirably or doesn’t give the exact
look you desire. You can also use Ctrl - Z (Windows, IRIX, and Linux) or Control-z (Mac OS X) to undo any undesired changes.

**Adding target objects to an existing blend shape**

In the next steps, you duplicate the face again and reshape the duplicate into a new facial expression. You then add the new face to the blend shape node to create another slider in the Blend Shape Editor.

**To create another facial expression**

1. Set the Blend Shape editor slider value to 0 to return baseFace to the position it had at the beginning of the lesson.
2. Make a duplicate of baseFace, name it raisedBrow, and move it to the left of baseFace so that all three faces are visible for comparison.
3. Make sure raisedBrow is selected.
4. In the perspective view, select Show > Isolate Select > View Selected. Select this menu item again in the front view.
Lesson 3 > Adding target objects to an existing blend shape

This displays only the selected object (raisedBrow) in the views. This is necessary to avoid selecting unwanted vertices in the next steps. The view’s label indicates isolate is turned on.

5 In the front view, position the pointer over the face, right-click and select Vertex. Drag a selection box around the vertices in the region of the eyebrows and forehead as shown below.

For these vertices, you need to select the vertices by dragging a selection box rather than by using the Paint Selection Tool. The eyebrows have vertices that lie behind its outer surface. The Paint Selection Tool selects only vertices at the outer surface. Dragging a selection box selects all vertices in the boxed region, including vertices that lie behind the outer surface.

6 In the side view, hold down the Ctrl (Windows, IRIX, and Linux) or Control (Mac OS X) key and drag a selection box around the vertices at the side of the head to turn off their selection (see the following figure).
7 Switch to wireframe display mode and dolly the camera from various close-up views to make sure you select all the vertices on and under the eyebrow. If you miss a few vertices, subsequent deformations will not work correctly. Also, make sure you don’t select vertices at the side or back of the head.

8 Select Deform > Create Cluster.

9 In the perspective view, turn off the selection of Show > Isolate Select > View Selected. Do this again in the front view.

   By turning off these menu selections, Maya displays all objects in the views again.

10 In the perspective view, drag the cluster up along its Y-axis a small amount until raisedBrow looks like the face on the left:
To add the new target object to the blend shape

1. In the Outliner, select raisedBrow and ctrl-select baseFace (the order of selection is important). The raisedBrow is the target, while baseFace is the base object.

2. Select Deform > Edit Blend Shape > Add > boxshadowup. In the options window, turn on Specify Node and enter blendShape in the BlendShape Node box. Click the Apply and Close button. When you created the blend shape for the smile, Maya created a node named blendShape that contains the slider attributes that adjust the blend into the smilingFace target. The Add operation creates a blend shape for the raisedBrow and adds it to the blendShape node. This adds a slider to the node’s Blend Shape editor for adjusting the raised brow deformations.

3. To display the Blend Shape editor, select Window > Animation Editors > Blend Shape.
You can use the sliders alone or in combination to create a smile with raised eyebrows, a frown with lowered eyebrows, and so on.

You can optionally select raisedBrow and edit the cluster weights to tune the deformation of the eyebrow region as desired. See “Editing cluster weights” on page 367 for details. An example weighting follows:
Beyond the lesson

In this lesson, you learned how to:

- Use two clusters and a blend shape deformer to manipulate facial expressions.

  In professional productions, it’s common to create several more clusters with a blend shape deformer for finer control of facial expressions. For example, you can create clusters for a number of mouth positions that you can use to simulate the phonemes of speech.

Tip

After you create a blend shape, you can optionally hide or delete a target object (in this lesson, smilingFace and raisedBrow). If you delete a target, you improve Maya processing time but lose the capability to manipulate the cluster handle. For versatility, many animators hide the target rather than delete it. Hiding the target is necessary when you render the scene. It is also useful when you want to unclutter the scene view.
When you used certain blend shape slider values, you may have noticed that the face looked good in all regions except for a few vertices. To fix such regions, delete the cluster, move the problem vertices of the target face to a better position, then create a blend shape for the improved target face.

As much as possible, use a target shape that’s not extremely different from the base shape. If you need to use an extremely different target shape, create a blend shape with multiple targets. Each of the multiple targets must have a shape that is progressively more like the extreme target shape. Before you create the blend shape, turn on In-Between in the Create Blend Shape options window, and select the multiple targets in this order: least extreme shape difference first, most extreme shape difference last.

Although the lesson showed how to blend individual objects, you can also blend hierarchies of objects. See the Maya Help for more information.

There are some additional notes on clusters which are not explained in this lesson:

- You can add or remove vertices from a cluster with Deform > Paint Set Membership Tool.
- You can use the Component Editor to edit weight values more precisely than by painting.
- Avoid changing the number of vertices (or CVs) for a surface after you apply a cluster or other deformer. Unexpected deformations may occur.