NURBS (Non-Uniform Rational B-splines) use a method of mathematically describing curves and surfaces that are well suited to 3D applications. NURBS are characterized by the smooth organic forms they produce.

NURBS surfaces can be quickly modeled and edited using a variety of techniques. NURBS surfaces are created using one or more NURBS curves that define the profile of the shape that you want for a surface, and then using a specific construction method to create the finished surface.

NURBS curves and surfaces have many applications and are the preferred surface type for industrial and automotive designers where smooth forms with minimal data are required to define a particular form. NURBS curves are ideal for defining a smooth motion path for an animated object. With NURBS, a surface can be modeled and then converted to a poly mesh.

In this chapter, you will learn some basic techniques for working with NURBS curves and surfaces in Maya. This chapter includes these lessons:

- “Lesson 1: Revolving a curve to create a surface” on page 127
- “Lesson 2: Sculpting a surface” on page 133
- “Lesson 3: Lofting curves to create a surface” on page 151
Preparing for the lessons

To ensure the lessons work as described, do these steps before beginning:

1. Select File > New Scene to create a new scene before starting each lesson.
2. Make sure the Construction History icon (below the menu bar) is on: 🗻. (If it is turned off, it has a large X across it.)
3. Select the Modeling menu set. Unless otherwise noted, the directions in this chapter for making menu selections assume you’ve already selected the Modeling menu set.
Lesson 1  Revolving a curve to create a surface

A simple technique for creating NURBS surfaces is to create a curve for the profile of your desired form and then create a surface using one of the various NURBS surfacing tools available in Maya. In this lesson, you create an egg holder using NURBS curves and the Revolve Tool.

In this lesson you learn how to:

• Create a NURBS curve using the control vertex (CV) creation technique.
• Use the grid for visual reference when modeling.
• Determine the start and end points for a NURBS curve and its direction.
• Create a revolved NURBS surface using the Revolve tool.
• Change the display shading smoothness for a NURBS surface.
• Edit a NURBS surface by editing its initial profile curve when it is linked to the surface by construction history.
Creating a profile curve

Revolve is a common modeling technique similar to shaping a vase on a spinning potter’s wheel. You must first create a profile curve in an orthographic view and use the Revolve Tool to create a surface.

To create a profile curve

1. Make sure you’ve done the steps in “Preparing for the lessons” on page 126.
2. Select Panels > Layouts > Four Panes so you can see multiple views of the scene.
   This is the most commonly used tool for drawing curves.
4. In the front view, click the numbered positions as shown in the figure. Make sure the first and last positions are on the grid’s Y-axis (the thickest vertical line of the front view’s grid).
   Also, click three times in the same spot for positions 9, 10, and 11. This is necessary to create a sharp point or corner in the curve.
   To change the position of the most recent point clicked, you can middle-mouse drag it.
5. (Windows, IRIX, Linux) After you click position 13, press Enter to complete the curve’s creation.
With the curve selected, select Surfaces > Revolve. This creates the egg holder surface from the revolved profile curve. Examine the results in the perspective view.

Maya does not delete the profile curve. In a subsequent step, you’ll edit the profile curve to alter the shape of the surface.

Select the surface and rename it Eggholder in the Channel Box.
3 With the pointer in the perspective view, press 5 (for Shading > Smooth Shade All). This displays the egg holder as a shaded surface rather than a wireframe in the perspective view.

4 Press 1, 2, and 3 to switch between the different degrees of display smoothness. (These hotkeys correspond to the menu items under Display > NURBS Smoothness.)

The finer the smoothness, the greater the impact is on interactive performance when you work with complex models.

The smoothness display only affects the scene view. Rendered images display with high quality smoothness regardless of this setting.

**Editing a revolve surface**

After you create a surface from a revolved curve, you can reshape the original creation curve to reshape the surface. This is possible because Maya’s Construction History feature was turned on before you did the revolve operation.

Selecting the original creation curve can be challenging when it is situated amongst other existing curves and surfaces. The Outliner is an editor that is useful for quickly examining the structure and components of a scene. The Outliner is also useful for selecting objects in situations like this.

**To edit a surface with construction history**

1 Select Window > Outliner.

The Outliner appears and displays a list of the items in the scene.
2 In the Outliner, select the curve you revolved (curve1) by clicking on its name in the list.

The curve becomes highlighted in the scene views.

3 In the front view, right-click in the view and select Control Vertex from the marking menu.

The CVs for the curve appear.

4 Select and move one or more CVs to adjust the curve shape as desired.

If you have trouble selecting one of the CVs in the front view, select it in the perspective view after dollying and tumbling the camera as necessary.

This modifies the shape of the egg holder because it is linked to the shape of the curve by its construction history.
5 If desired, save the scene for future review.
6 Close the Outliner window.

**Beyond the lesson**

In this lesson you were introduced to a few basic techniques related to NURBS modeling:

- Revolving a curve is the easiest way to create surfaces with radially symmetrical forms—wheels, vases, glasses, pillars, and so on.
- NURBS surfaces are webs of interconnected curves. The creation curves are used to create and subsequently modify the surfaces if required.
- Proficiency at drawing and editing curves is an important part of NURBS modeling.
- The grid is a useful aid for constructing and modifying curves.

Some additional points you should know are:

- You cannot render curves, so your work with them is always an adjunct to creating and editing surfaces.
- Besides moving a curve’s CVs to alter its shape, you can cut, attach, extend, close, and smooth curves.
- After you create a surface from a revolved curve, you can edit the surface at a component level by moving CVs or scaling groups of CVs on that surface to customize the shape of the surface. (You will need to turn off construction history in order to do this.)
Lesson 2  **Sculpting a surface**

In addition to creating NURBS surfaces using curves, you can edit and sculpt surfaces and primitive objects in Maya using the Sculpt Surfaces Tool.

The Sculpt Surfaces Tool allows you to interactively push or pull on the surface regions to create areas that are embossed or in relief in relation to the surface.

In this lesson, you learn some of the basic concepts of these tools by sculpting a cartoon face and head from a NURBS primitive sphere using the Sculpt Surfaces Tool.

In this lesson you learn:

- Basic sculpting operations (push, pull, smooth, and erase) with the Sculpt Surfaces Tool.
- How the density of isoparametric lines affects the surface detail possible when sculpting.
- How to increase the surface subdivisions on a NURBS surface to aid with surface sculpting.
- How to change the brush radius for the Sculpt Surfaces Tool.
- How Opacity and Max Displacement affect the sculpting operations.
- How to import geometry from a pre-existing file into your current scene.

**Preparing a surface for sculpting**

Because a head is roughly spherical, you can create a primitive sphere as a quick starting point for creating a head and face.
To prepare a sphere for sculpting

1. Make sure you’ve done the steps in “Preparing for the lessons” on page 126.

2. Select Create > NURBS Primitives > Sphere > □. In the options window, select Edit > Reset Settings, enter the following values, then click the Create button:
   - Radius: 6
   - Number of Sections: 30
   - Number of Spans: 30

The Radius sets the sphere’s size in grid units. A value of 6 creates a sphere big enough to use the grid for size comparison.

The Number of Sections sets the number of vertical curves, called isoparms, for the sphere. Isoparms show the outline of the surface shape. The more isoparms a surface has, the more CVs it has. (By default, CVs are not displayed.) More CVs means better precision as you edit a surface. The Number of Spans sets the number of horizontal isoparms.

The drawback to having too many CVs is that you’ll have a harder time making smooth shape changes to broad regions. Lots of CVs also means slower processing time as you work with the surface. It’s best to make surfaces with as few CVs as necessary.
We chose 30 Sections and Spans for this lesson because experience has shown that this allows adequate facial subtlety without slowing Maya operation on a workstation of modest processing power.

### Note

In wireframe display mode, if you select Display > NURBS Smoothness > Fine or Medium, more isoparms appear than there are actual spans and sections. The surface is visually displayed with extra precision, but the extra isoparms have no CVs and cannot be edited.

3 Name the sphere Egghead.

4 Rotate the sphere 90 degrees on its side (Rotate Z: 90). This positions the sphere’s CVs well for modeling a simple head and face. You’ll learn why later in this lesson.

5 To give Egghead an oval shape, set the ScaleX for the sphere to 1.3 or so. Optionally, you can move Egghead above the grid so the grid doesn’t interfere with your view of Egghead. Also, position the camera view so the Z-axis of the View Axis points toward you.

### Modifying the surface material for easier viewing

Because you will do subtle surface modeling in this lesson, it’s helpful to display Egghead with bright highlights so you can clearly see the effects of the changes you make. In the next steps, you’ll assign a Blinn material to Egghead to give its surface bright highlights. The steps have no explanations, as the shading subject matter is the focus of a later lesson.
To assign a Blinn surface material

1. With Egghead selected, press 5 to display the surface with smooth shading.

2. Right-click Egghead and select Materials > Assign New Material > Blinn.
   
   The Attribute Editor will immediately be displayed for the Blinn material.

3. Drag the Color attribute slider roughly 3/4 of the way to the right, set Eccentricity to 0, and close the window.

Basic sculpting techniques

In the next steps, you’ll become familiar with features of the Sculpt Surfaces Tool. With this tool, you use your mouse or stylus to push, pull, or smooth a surface’s shape without selecting or displaying CVs. After you practice sculpting the surface, you’ll erase your practice strokes then begin sculpting Egghead’s features.

To practice sculpting using basic sculpting operations

1. With Egghead selected, select Edit NURBS > Sculpt Surfaces Tool > \Box. In the Tool Settings window, click Reset Tool, and make sure the Sculpt tab is displayed.
In the Sculpt Parameters section, there are four operations for sculpting a surface. Each affects the region of the surface where you drag (stroke) your mouse or stylus relative to the surface normals:

- The **Push** operation depresses the surface in the region of the stroke.
- The **Pull** operation raises the surface in the region of the stroke.
- The **Smooth** operation diminishes bumps or ridges where you drag.
- The **Erase** operation eliminates the effects of the other three operations. The Erase operation works up to the last time you saved the scene or clicked the Update button to the right of Erase Surface.

2 Experiment with each of the four operations on the surface. Don’t be concerned with the results. Just become familiar with the response to your mouse strokes.

By default, Push and Pull strokes deform the surface in a direction normal (perpendicular) to the surface. To create the resulting deformation more accurately, use Push and Pull strokes in a front, side, or top view while examining the results in a separate perspective view. Tumble the perspective view regularly for best visual feedback.

When you position the mouse pointer on the surface, it changes to a red sculpt icon that shows an abbreviation for the name of the operation you are performing. For instance, Ps stands for Push.

The red icon also displays the radius of the region affected by the stroke. The Radius(U) value changes the radius.
3 Select the Erase operation and click the Flood button. This erases all your changes.

4 Select the Pull operation and enter a Radius(U) of 0.25, then drag between a pair of horizontal isoparms without crossing either.

This has no effect because the stroke radius didn’t make contact with the CVs of either isoparm. Regardless of which operation you use, only CVs are affected by the strokes.

5 Change the Radius(U) to 2 and repeat the prior strokes.

The strokes alter the surface because the radius overlaps the CVs. As this example shows, you need to make sure the radius is big enough to influence the desired CVs. It’s common to change the radius many times during a sculpting session.

If you prefer to affect a small region without increasing the radius, you can add CVs to the region by inserting more isoparms. You’ll do this later in the lesson.

6 Flood-erase the changes to the surface as you did previously.

7 Select the Pull operation with a Radius(U) of 0.5. Drag along a vertical isoparm. For comparison, drag along a horizontal isoparm.
The vertical stroke creates a thinner ridge than the horizontal stroke because the density of vertical isoparms is greater. The number of underlying CVs and their positioning affects the outcome of your strokes.

Tip

You can alternatively adjust the radius of the sculpting tool using a Hotkey. Move the tool over the object, press and hold the b Hotkey and drag left or right. The circle on the object with numerical radius value represents the size of your tool. Stroke on the object to try out a new size.

8 Flood-erase the changes to the surface as you did previously.

9 Rotate the camera view so the X axis of the View Axis points toward you. Draw a vertical Pull stroke again.
As your stroke nears the center of Egghead, a kink occurs. It’s challenging to alter a surface symmetrically in a region where many isoparms converge at a single point, called a *pole*. Always consider the position of isoparms as you sculpt a surface. In general, sculpt where isoparms are evenly, regularly distributed.

10 Erase all changes again, then reposition the camera view so the Z-axis of the View Axis points toward you.

**Tip** If the Sculpt Surfaces Tool is selected but not the surface you want to work on, right-click the surface and select Select from the marking menu.

**Additional sculpting techniques**

Now that you’ve learned the basic features, you’ll learn other useful techniques before starting to model the facial features.
To practice additional sculpting techniques

1. In the Sculpt Parameter section of the Sculpt Surfaces Tool, set Max Displacement to 2.
2. Draw a vertical Pull stroke.
3. Change the Max Displacement to 1.
4. Draw another vertical stroke nearby.
   The Max Displacement sets the maximum distance the surface’s CVs are pushed (or pulled) with a single stroke.
5. Erase the changes to the surface.
7. Draw a vertical Pull stroke.
8. Set the Opacity from the default value of 1 to a value of 0.2.
   One ridge is higher than the other. The Opacity value scales the influence of Max Displacement. For example, with an Opacity of 0.2, each stroke has only roughly 0.2 times the effect of the Max Displacement setting.
   It’s generally best to use a low Opacity value as you Push or Pull. You can increase the deformation gradually with multiple strokes.
   If you want to affect only a small region of a surface, use your mouse to click rather than stroke the region. If the Radius(U) and Opacity of the brush is small, you might need to click the nearest intersection point of two isoparms.
10 With Opacity set to 1, erase all changes to the surface again.

**Tip**
Consider using an electronic tablet with pen stylus. A pen stylus is more natural for stroking surface changes as it feels like a pen. With a stylus, you can set an option that causes the Radius or Opacity to vary with stylus pressure. For example, you can have heavy strokes create a bigger Radius than light strokes.

To do this, display the Stroke tab of the Sculpt Surfaces Tool. For Stylus Pressure, select Opacity, Radius, or Both. Radius is a common choice. If you select Radius, the Radius(U) value on the Sculpt tab sets the maximum radius, while Radius(L) is the minimum. Explore various settings.

If you use a mouse, set the Stylus Pressure to None. The Radius(U) sets a fixed radius. Radius(L) is ignored.

**Sculpting a nose**
Now you’ll begin sculpting Egghead’s face, starting with a simple nose.

**To sculpt a nose for the character**

1 Position the perspective view so the Z-axis of the View Axis points toward you.
2 Reset the Sculpt Surfaces tool.
3 Select the Pull operation and set the following options:
   - Radius(U): 1
   - Opacity: 0.2
4 Select this Shape setting so your strokes have a soft, faded edge:
Above the midpoint of Egghead, stroke vertically downward from the top of the nose to the tip—about the distance between two horizontal isoparms (see the following illustration). Use several strokes to build up the bridge of the nose. Create nostrils by stroking horizontally to the right of the tip of the nose a few times, then to the left of the tip a few times.

To build up a small area, position the stroke icon there and click the mouse rather than drag. Tumble the view to examine your results after each stroke or click.

If the strokes create a bumpy surface, turn on the Smooth operation and click Flood once or twice to smooth all strokes on the surface. Because Opacity is 0.2, the Smooth operation is subtle. Alternatively, you can smooth a selected region by stroking just that area. It’s common to smooth a surface regularly while using pull and push strokes.

Because there are relatively few isoparms in the nose area, you can only create a simple nose that’s broad and rounded. If you want to create sharper features, for instance, depressed nostrils or sharp ridges, you’ll need to insert isoparms in the nose region. “Sculpting a mouth” on page 145 describes how to insert isoparms.

**Sculpting eye sockets**

Eye sockets provide an inset and backdrop for eyes.

**To sculpt eye sockets for the character**

1. Select the Push operation.
2. Leave other settings the same as for the nose.
3 To make a pair of identical eye sockets, display the Stroke tab of the Tool Settings window and turn on Reflection. Position the sculpt icon on Egghead. A pair of identical Push icons appears on Egghead.

4 Adjust the positioning as desired for the sockets. Click the mouse many times in the desired location.

In your future work, keep in mind that on some surfaces, the position of the mirrored stroke icons might appear vertically or diagonally opposite one another rather than horizontally. There’s a simple technique for adjusting the positioning. With Reflection and U Dir turned on, try various slider positions for U Dir. If the positioning isn’t correct, turn on V Dir and try various slider positions for V Dir. Make subtle adjustments by moving the brush icon.

**Sculpting eyebrows**

Eyebrows help define how stern or pleasant a face appears.

**To sculpt eyebrows for the character**

1 Select the Pull operation. Use the same option settings as for the eye sockets, including Reflection.
Position the sculpt icons above the eyes and draw horizontal strokes. If necessary, click positions where you need to build up the eyebrows. Smooth the eyebrows as necessary.

**Sculpting a mouth**

With the 30 Sections and 30 Spans specified for the original sphere in this lesson, the large space between isoparms in the mouth region makes it impossible to create a subtle shape for the lips.

To overcome this problem, you must insert isoparms in the mouth region before sculpting.

**To insert additional isoparms**

1. Right-click Egghead and select Isoparm from the marking menu.
2 From the Toolbox, choose the Select Tool.

3 Click the horizontal isoparm below the nose and shift-click the next two below it.

4 Select Edit NURBS > Insert Isoparms \(\Box\). In the options window, turn on Between Selections, enter a value of 2 for \# Isoparms to Insert, then click Insert.

This inserts two extra isoparms between each pair of selected isoparms, for a total of four extra isoparms. This provides enough CVs to create subtlety in the mouth.
You might want to add vertical isoparms at the lips in a similar way. The extra isoparms would also be useful if you were to later enhance the shape of the nose. Insert isoparms only where needed. More isoparms means slower processing speed.

In any case, do not change the number of isoparms by editing the original number of Sections and Spans in the makeNurbSphere history node. This will reshape your sculpted surface undesirably.

To sculpt a mouth for the character

1. Select the Sculpt Surfaces Tool again.
2. Select the Push operation. Enter 0.2 for Radius(U). In the Stroke tab, make sure Reflection is turned on.
3. Starting at the center of the area appropriate for the indentation between the lips, stroke outward from the center. It’s best to start the stroke with the dual icons on top of one another (in other words, only one icon is displayed).
4. Select the Pull operation and set the Radius(U) to 0.3. Using a similar technique as for the prior step, stroke the upper lip. Repeat for the lower lip.
Sculpting other facial features

You can now optionally add other facial features. Consider these tips:

- For facial features such as the chin, cheeks, and forehead, use a Radius(U) larger than 1 and start with a Maximum Displacement between 0.5 and 1.
- Insert isoparms wherever you want to add extra detail with the Sculpt Surfaces Tool.
- To create eyeballs for the sockets, create a sphere and scale it as necessary to fit the socket. You might want to increase the eyeball’s Scale X value to make it oblong. To duplicate the eyeball, and make a mirrored copy of the original you’ll first need to set the pivot point for the eyeball to be at the origin 0, 0, 0 using the following steps. With the sphere selected, press the Insert (Windows, IRIX, and Linux) or Home (Mac OS X) key so that the sphere’s pivot point is displayed. Next move the pivot point to the origin using the X hotkey so that the pivot snaps to the grid at 0, 0, 0. Select Insert (Home) to turn off the pivot point display. Finally, use Edit > Duplicate > □ and set the Scale setting to -1, 1, 1. This makes the new eyeball a mirrored duplicate of the original on the opposite side of Egghead’s face. Position the eyeballs in the sockets. Parent the eyeballs to Egghead.

Note
It might be easier to push or pull the lips with the Ref. Vector set to Z Axis. This moves the region you stroke in the world Z-Axis direction. The default Normal setting moves the region in a direction normal (perpendicular) to the surface. Because the normal direction on a lip might be up, down, or straight out, depending on the part of the lip you stroke, there’s more possibility of undesired results when you use the Normal setting.
To create simple, unadorned ears, you can create, scale, and squash a sphere. Create ridges and valleys by pulling CVs or by using the Sculpt Surfaces Tool. Duplicate the ear by first setting its pivot point to the origin and with the Scale option set to -1, 1, 1. Parent the ears to Egghead.

**To import existing models into your scene:**

If you saved the Eggholder scene in the prior lesson, you can import the egg holder into this Egghead scene, then position Egghead into the egg holder.

1. To import the egg holder into the Egghead scene, use File > Import and select the name of the scene that contains Eggholder.
   
   Importing a scene imports all objects from that scene.

2. Increase (or decrease) the scale of the egg holder (or Egghead) as necessary for a snug fit.

**Beyond the lesson**

In this lesson you were introduced to a few basic techniques related to sculpting surfaces:

- The Sculpt Surfaces Tool is indispensable for quickly shaping a variety of surfaces. As you do your own projects, pay special attention to the position and density of isoparms before you begin sculpting.

- Isoparms converge at a single point (the pole). Pole regions of a primitive or surface are hard to sculpt so it’s best to avoid using the Sculpt Surfaces Tool there. For example, when you created the original sphere in this lesson, you rotated it 90 degrees around its Z-axis. Because of the rotation, ears for the...
head would need to be modeled via a different technique (for example, you could model a pair of ears and parent them to the head.)

- The density and orientation of isoparms on a surface affects the results with the Sculpt Tool. As you gain NURBS modeling experience, you’ll learn how to use the density and orientation of isoparms to your advantage.

- Primitive objects are useful objects for sculpting in many cases. After you create a primitive, you typically sculpt, scale, trim, or otherwise alter the object into a more complex shape. Though most primitives are surfaces rather than curves, they still derive their shape from curves.

In general, a sphere makes a convenient foundation for creating a simple head, but it’s not ideal if you plan to animate an expressive, talking head. Many 3D artists start with a cylinder or a lofted surface. The procedures for doing this are more complex than starting with a sphere and beyond the scope of this lesson.
Lesson 3  Lofting curves to create a surface

Another method for creating NURBS surfaces is to loft a series of curves that define the cross section of your desired surface form. Lofting a surface works like stretching a skin over each of the cross sections to create the final surface.

In this lesson, you learn additional NURBS surfacing techniques by using the Loft tool to create the body of a salt shaker. You will also create the cap for the salt shaker by modifying the shape of a primitive sphere.

In this lesson you learn how to:

• Modify the outline of a circle primitive by editing the position of its CVs.
• Use the magnet snap feature.
• Loft cross section curves to create a NURBS surface using the Loft tool.
• Edit the form of an existing primitive object by moving its CVs.
• Parent one object to another using the Outliner.

Creating profile curves for a surface

You begin the lesson by creating a pair of profile curves. You then create several copies of these curves to form the skeletal contours of the salt shaker’s surface.

To create profile curves for the salt shaker’s body

1. Make sure you’ve done the steps in “Preparing for the lessons” on page 126.
2 Select Create > NURBS Primitives > Circle > . In the options window, select Edit > Reset Settings, enter the following values, then click the Apply button:

- Radius: 4
- Number of Sections: 24

The Radius sets the size of the circle in grid units. A value of 4 creates a circle with enough size so that you can use the grid for convenient size comparison.

The Number of Sections sets the number of CVs in the circle. By using 24 CVs, you can create a circle with the subtle contours required in this lesson. Display the CVs of the circle to see the 24 CVs.

A circle is a curve that loops back on itself. The CVs work the same way as for any other curve. The more CVs you create for a curve or surface, the more detail you can give its shape.

The drawback to using many CVs is that you’ll have a harder time making smooth shape changes to broad regions. Also, more CVs means slower processing time as you work with the curve. It’s best to make curves with as few CVs as necessary. With experience, you’ll learn how many CVs to use in a situation.

3 Create another circle, this time with these options:

- Radius: 2
- Number of Sections: 24

This creates a smaller circle inside the first circle as shown below.

4 Change the scene view so you can see the circles from the top view.
Lesson 3 > Creating profile curves for a surface

5 Right-click the inner circle and select Control Vertex from the marking menu. Repeat for the outer circle.

6 Turn on Snap to Points (below the menu bar).

7 As shown in the following figure, move CVs from the outer circle to the corresponding inner circle positions. As you drag a CV near its destination, the Snap to Points mode causes the CV to jump to the exact CV position.

8 Turn off Snap to Points. Turn off the display of CVs for both circles by right-clicking on the circles and selecting Object Mode from the marking menu.
Duplicating curves

In the next steps, you’ll create several copies of the previously created circles (also called curves) to form the skeletal contours of the salt shaker’s surface.

To duplicate curves for the lofted surface

1. Right-click the outer curve and choose Select from the marking menu.
2. Select Edit > Duplicate > /box. In the options window, select Edit > Reset Settings, enter the following values, then click Duplicate:
   - Translate: 0 3 0
   - Scale: 0.93 1 0.93
   - Number of Copies: 4
   This creates four copies of the original curve, each translated three units above the last, and each scaled smaller than the last.
3. Select the inner circle and then move it to 0, 13, 0 by entering these translate values in the Channel Box. Increase its Scale attributes to 1.33, 1.33, 1.33.
4. Use Edit > Duplicate > /box with the following options:
   - Translate: 0 2 0
   - Scale: 1.05 1 1.05
   - Number of Copies: 3
   This creates three copies of the circle, each translated two units above the last, and each bigger than the last.
Lofting a surface

You’ve created a total of nine curves. In the next steps, you loft these curves into a surface that matches the contours of their perimeters. Above the midpoint of the surface, the shape will change from a flower-shaped perimeter to a circular perimeter.

To loft a surface for the salt shaker’s body

1. Shift-select all circles, one at a time.
   The order of selection is important when shift-selecting for a loft operation. You must start with the bottom flower-shaped circle and end with the top circular-shaped circle. Alternatively, you can drag a selection box around the circles. The surface to be lofted will be based on the selection order of the curves.
2. Select Surfaces > Loft.
   This creates the salt shaker’s body.
3. Name the surface shakerBody.
4. Press 5 to display the view with smooth shading.
Modifying a primitive object

To create a simple cap for the salt shaker, you’ll create a sphere, alter its shape, and position it above the body.

To create and modify a sphere for the salt shaker’s cap

1. Select Create > NURBS Primitives > Sphere > □. In the options window, select Edit > Reset Settings, and click the Create button. Maya puts the sphere at the origin, its display currently obstructed by the salt shaker body.

2. Name the sphere Cap.

3. Move the cap to the top of the body.

4. Scale the cap size so that its diameter fits snugly at the top of the body.

5. Adjust the cap’s position as desired.

6. In a side view, make sure that the cap is displayed as a wireframe.

7. Right-click on the Cap and choose Control Vertex from the marking menu.

8. Select the top row of CVs and drag them down until the top of the cap is flattened:

Note: Many of the surface creation tools also have the option of creating polygon or subdivision surface versions of a surface with the same input curves. You do this by setting the appropriate Output Geometry option for that particular surface tool.
Check that the bottom half of the cap isn’t poking through the visible surface of the body. You can scale the bottom CVs inward to avoid this problem.

**Using the Outliner to parent objects**

The Outliner is an editor that is useful for quickly examining the structure and components of a scene. You can use the Outliner to quickly parent objects to create an object hierarchy.

**To parent an object using the Outliner**

1. From the main menu, select Window > Outliner. The Outliner window is displayed. A list of the scene’s components is listed in the Outliner.
2. In the Outliner, click on the word Cap to select it.
3. Parent the cap to the body by middle-mouse dragging Cap onto Body in the Outliner.
By parenting the objects, you can move, rotate, or scale the cap and the body as a single entity by selecting only the body. Notice that the salt shaker displays horizontal curves that wrap around the body. The curves are the original circles you used to loft the surface. Because these curves are part of the surface’s construction history, you can alter their shape if you decide you want to alter the shape of the body and the body will update based on the construction history.

If you prefer not to see the curves in the scene view, select the curves and select Display > Hide > Hide Selection. The curves won’t appear when you render an image of the scene. Maya displays only surfaces, not curves, in rendered images.

**Beyond the lesson**

In this lesson you were introduced to the basic techniques related to lofting curves to create NURBS surfaces:

- You made a salt shaker with two surfaces: a body made from lofted curves and a cap made from an altered sphere. An advantage of creating a separate surface for the cap and base is that you can easily give each a different color or texture, for example, one chrome and the other marble. Another advantage of creating a separate cap is that you can animate the object separately. For example, you could choose to animate the cap unscrewing from the shakerBody.
You used a Loft operation rather than a Revolve operation to create the body. The vertical corrugations on the surface would be impossible to create by revolving a curve.

You can alter the position of the profile curves and the shape of the shaker will update because of the construction history. If you’re certain you won’t change the body’s shape by editing the shape of the lofted curves, you can delete the body’s construction history to quicken Maya’s processing of your interaction with the surface. (For a surface as simple as the salt shaker, deleting the history won’t boost processing much.)

There are many other useful tools for creating and editing surfaces. For a glimpse of the possibilities, take a look at the Surfaces menu and the Edit NURBS menu.

If you want to learn more about a particular tool or feature that has been presented in this lesson, please refer to the Maya Help.
4 | NURBS Modeling
Lesson 3  > Beyond the lesson