In Maya, *modeling* refers to the process of creating virtual 3D surfaces for the characters and objects in the Maya scene. Surfaces play an important role in the overall Maya workflow as they are the items upon which shading and texture attributes will be assigned. It is these attributes that assist in the creation of a convincing 3D image. The more accurate you are when modeling your forms in terms of size, shape, detail, and proportion, the more convincing your final scene will become.

There are three modeling surface types in Maya:

- Polylons
- NURBS
- Subdivision surfaces.

Each surface type has particular characteristics and benefits, and requires specific modeling techniques. Maya groups the surface modeling tools in a menu set specific to modeling.
Polygon surfaces are a surface type comprised of flat surfaces called *faces*. You can create a single polygonal face or a network of polygonal faces called a *poly mesh*. A poly mesh is comprised of many faceted three-or-more flat sided polygon faces. When a poly mesh is rendered, it is shaded smoothly so that the facets are not as apparent in the final image.

Polygonal surfaces can be used to create virtually any type of surface shape and are particularly useful when simple forms are required. Polygonal surfaces have a wide range of applications and are the preferred surface type for interactive games and web development applications. Polygonal surfaces are described with the smallest amount of data, and therefore, can be rendered more quickly, delivering increased speed and interactive performance to the end user.

**Preparing for the lesson**

To ensure the lesson works as described, do these steps before beginning:

1. Select File > New Scene to create a new scene.
2. Make sure the Construction History icon (below the menu bar) is on: (If it is turned off, it has a large X across it.)
3. Select the Modeling menu set. Unless otherwise noted, the directions in this chapter for making menu selections assume you’ve already selected the Modeling menu set.
4. Make sure Display > UI Elements > Help Line is turned on. You will use the Help Line while modeling.
Lesson 1  Modeling a polygonal surface

In this lesson, you model a simple hammer, starting from a cube primitive, using polygonal surface modeling techniques.

In this lesson you learn how to:

- Differentiate the basic components of polygonal surfaces.
- Use primitive objects as the basis for more complex polygonal models.
- Select the faces, edges, and vertices of polygonal meshes using your right mouse button.
- Extrude faces from an existing poly model to add detail.
- Move and rotate extruded polygonal meshes using the polygonal transformation manipulator.
- Split vertices and subdivide polygonal faces.
- Smooth polygons to make the model appear less faceted.
- Use the grid magnet feature.
Creating a foundation shape from a primitive

You begin the lesson by creating and scaling a cube into the rough shape of a hammer handle. You’ll extrude a face of the handle to create a small box shape that you will use as the foundation for the head of the hammer.

To create a foundation shape

1. Select Create > Polygon Primitives > Cube > □. In the options window, select Edit > Reset Settings and click the Create button.
2. With the pointer in the perspective view, press 5 (for Shading > Smooth Shade All).
3. Scale the cube into the general shape of a hammer handle. You’ll enhance the shape later.
4. Move the cube so that its bottom lies on the grid (see illustration).
5. Right-click the cube and select Face from the marking menu. Maya displays small squares at the centers of the faces. To select a face, you select the small square.
6. Select the face center at the top of the cube. Whenever you select a face, tumble the view in several directions to check that you’ve selected only the desired face.
3 | Polygonal Modeling
Lesson 1 > Creating a foundation shape from a primitive

7 Select Edit Polygons > Extrude Face.
Maya creates a new face in the same position as the previously selected one. The extrusion manipulator works like a combined Move, Rotate, and Scale Tool, but it modifies the new face rather than the whole object.

8 Drag the blue arrow up a little to extrude the face (see the following figure). The blue arrow turns yellow when selected. The resulting extension to the surface will become the middle section of the hammerhead between the claw end and the pounding end.
Examine the parts of this manipulator, as shown in the following illustration. It is called the Show Manipulator Tool and appears for various operations throughout Maya.

If you cancel the selection of the face, the manipulator disappears from the face. To display the manipulator again, select the face, select Modify > Transformation Tools > Show Manipulator Tool, then click the polyExtrudeFace# in the Channel Box.
Splitting polygons

Now you’ll split one of the faces of the extruded shape into two parts. From these two parts, you’ll create the claw end of the hammerhead.

To split polygons and manipulate the foundation shape

1. Select Edit Polygons > Split Polygon Tool.
2. Click one of the top, narrow edges as shown.

3. Middle-drag the point roughly to the edge’s midpoint. If you are a perfectionist, examine the Help Line as you drag the point. When you see Percentage: 50%, the point is at the midpoint.

4. Click the bottom edge of the face and similarly drag the pointer to its midpoint. Press Enter (Windows, IRIX, and Linux) or Return (Mac OS X) to divide the face into two.

5. Right-click the cube and select Vertex from the marking menu.

A single face split into 2 faces
6 Select the vertices at the top and bottom of the edge that divides the two faces. (If the vertices are hard to see, press 4 to select wireframe display mode.) Examine the object from several camera views to make sure you haven’t accidentally selected extra vertices.

7 Select Edit Polygons > Split Vertex. The reason for splitting the vertices is explained later.

8 Shift-select the two split faces. (To display the face centers, right-click the cube and select Face from the marking menu.)

9 Select Edit Polygons > Extrude Face > \( \square \). In the options window, open the Other Values section and enter 6 for Divisions, then click the Extrude Face button. You may need to scroll the option window to access the Divisions option.

A manipulator appears on one of the faces. Because two faces were selected when you selected Extrude Face, the manipulator controls the extrusion of both faces.

10 Drag the blue arrow outward to extrude the faces to a length appropriate for a hammer claw.
When you extrude the faces, the length of the extruded surface will have six subdivisions rather than the default single subdivision. With the extra subdivisions, it will be easier to modify the extrusion into a claw shape in a later step.

11 Drag the red scale manipulator (the small cube) inward to narrow the blades, then drag the green scale manipulator up to flatten the blades at their tips. (See the next figure.) This creates the preliminary shape of the hammer’s claw.

In a prior step, you split the vertices at the top and bottom of the edge that divided the two faces. This created two additional, overlapping vertices at each split vertex (a total of
 six vertices). The extra vertices were necessary to create a gap between the blades. Without the extra vertices, the two blades would be a solid single blade.

If you had extruded each face individually to create the two blades, you would not have needed to split the vertices to create the gap. However, it would have been harder to make the two blades exactly the same length, width, depth, and so on.

When you extrude two or more faces at the same time, the manipulators influence both identically. Symmetry is ensured.

**Using the poly extrude manipulator**

Now you’ll enhance the curvature of the claw’s blades and split the blades apart more. You will use the same extrude manipulator. If the manipulator is not displayed because you mistakenly cancelled the selection of the faces, select the extruded faces of the claw, select Modify > Transformation Tools > Show Manipulator Tool, and click polyExtrudeFace2 in the Channel Box.

**To modify the claw’s shape using the manipulator**

1. Click the large circle surrounding the manipulator to display the rotate manipulators. Drag the red circular manipulator down a bit to rotate the extrusion (see the following figure).
Rotating the angle of extrusion will help you to shape the claws downward in the next few steps.

2 Drag down the green and blue arrows a short distance to begin shaping the claw downward.

3 Right-click any part of the surface and select Vertex from the marking menu. Each subdivision of the claw has a group of vertices that separate it from the adjacent subdivision (see the following figure). Move each of these groups down or up a small distance to make the claw arch downward. (Drag one group of the vertices at a time.) You can shift-drag to constrain the movement of the vertices to a straight line.

Two views of a completed example follow:
In the next steps, you’ll extrude a face to create the pounding end of the hammerhead.

**To extrude the pounding head for the hammer**

1. Select the back face of the polygonal hammerhead.
2. Select Edit Polygons > Extrude Face > □. In the options window, set Divisions to 1 and click the Extrude Face button. Move the face outward a short distance.

Also scale the extrusion inward along all three axes. To do this, click any of the scale manipulators to display a general scale manipulator at the center of the manipulator axes. Drag the center manipulator left to shrink the overall scale. This tapers the middle section of the pounding end of the head.
3 | Polygonal Modeling
Lesson 1 > Using the poly extrude manipulator

3  Select Edit Polygons > Extrude Face again and move the face outward again. Scale the extrusion outward along all three axes.

4  Select Edit Polygons > Extrude Face one more time and move the face outward. Leave the scale the same as the last extrusion.

To create a depression at the top of the head

Now you’ll extrude the top of the hammerhead inward and down to create a pit or depression. Hammers often have such pits where the handle is fastened to the head.

1  Select the face at the center top of the hammerhead.
3 | Polygonal Modeling
Lesson 1 > Subdividing polygon faces

2 Select Edit Polygons > Extrude Face and scale the extrusion inward along all three axes.

3 Select Edit Polygons > Extrude Face and drag the extrusion down. This creates the pit in the hammerhead.

Subdividing polygon faces
A real hammer handle is narrower near the head than at the base. In the next steps, you’ll adjust the width of the handle. First, you need to subdivide the faces of the handle to add extra vertices.
Currently the handle has only four vertices, one at each corner. With vertices only at the corners, you can taper the ends of the handle but not other regions. By creating extra vertices throughout the handle, you can tune the shape wherever you choose.

**To subdivide the handle**

1. Shift-select the faces of the handle, including the bottom face. Dolly and tumble the view to see all the faces to select them.

2. Select Edit Polygons > Subdivide > . In the options window, enter 2 for Subdivision Levels, then click the Subdivide button.

   This divides the selected faces into multiple faces with corresponding extra vertices. You can then make fine alterations to the handle’s shape.

   You could have subdivided the handle faces using the Split Polygons Tool described earlier in the lesson. Subdivide is easier to use because you merely select the face you wish to subdivide. You don’t need to select exact positions on the faces. The disadvantage is that you might end up with more faces and vertices than you want to work with.

   The advantage of the Split Polygons Tool is that you create only the number of faces and vertices you want, which makes the surface simpler to edit and faster for Maya to process.
3 To see the vertices, right-click the hammer and select Vertex from the marking menu. Display the hammer in wireframe mode by clicking the 4 hotkey.

4 Scale each row of vertices on the handle inward as desired. A row refers to the vertices that are at the same height along the edges of the handle. If a few vertices lie at an odd location, that is, they lie a little above or below a row, move them into a position even with the row.

Besides scaling a row of vertices, you can also move a row of vertices up or down the handle to alter the contours.

In the next part of the lesson, you’ll smooth the edges of the hammer so it looks more authentic. Before doing this, you might want to tune the hammer’s shape by modifying your prior extrusions or by moving or scaling vertices.

5 To modify an extrusion, first select the face or faces, and then select Modify > Transformation Tools > Show Manipulator Tool. Next, click each polyExtrudeFace# in the Channel Box until the extrude manipulator appears on the desired extrusion.
You can move and scale a face with the standard Move Tool rather than the Show Manipulator Tool. However, the Show Manipulator Tool moves the face in the direction of the surface normal rather than in a direction along the View Axis. This surface normal direction is usually the desired direction.

**Smoothing edges**

Now you’ll smooth the edges of the hammer. Smoothing the edges adds more vertices, which means it will be harder to select vertices when you reshape the surface thereafter. Generally it’s best to hone the shape as much as possible before you smooth edges.

**To smooth the polygon edges and make final modifications**

1. Decide which edges you want to smooth. For each edge to be smoothed, select the faces that lie on each side of it. For example, to smooth all edges except those on the claw, select the faces as shown in the following illustration.
3 | Polygonal Modeling
Lesson 1 > Smoothing edges

2 Select Polygons > Smooth. After smoothing, you may see some vertices at improper positions. For example, you might see a vertex jutting out at the base of the handle.

3 Select each improperly positioned vertex and move it to a position where the surface looks symmetrical. Strive for uniform, regular vertex and edge positions.

If there are improperly positioned edges or extra edges that make the hammer lumpy, you can either select them and move them or delete the unwanted edges by using the Edit Polygons > Delete Edge tool. If you need to add an edge, do so with Edit Polygons > Split Polygons Tool as shown previously in the lesson.
3 | Polygonal Modeling
Lesson 1 > Smoothing edges

4 Notice how the pounding end of the hammerhead has a rounded shape. On a real hammer, this end is flat. To flatten the end, select the vertices there. It’s easiest to do this in a front view by dragging a selection box around the vertices.

5 In the Toolbar double-click the Move Tool so the tool settings window is displayed.

6 Turn off Retain Component Spacing under the Move Snap Settings section. This will ensure that the following steps work as described.

7 Turn on Snap to Grids: 

8 Move the vertices straight out from the head until they snap to a position while working in an orthographic view. This makes the vertices lie on the same plane, though maybe not the plane you want.

9 Turn off Snap to Grids, then drag the vertices back toward the hammerhead to the desired position.

10 Feel free to enhance the positioning of other vertices anywhere on the hammer. You can smooth edges more than one time. For example, if you want a more rounded pounding face, select the faces surrounding the edges of the pounder and use Polygons > Smooth again.
The hammer will look smoother when you render an image from the scene as compared to displaying it in the scene view. Examples of rendered images follow:

Beyond the lesson

In this lesson you were introduced to some fundamental facts and techniques of polygonal modeling:

- You can create complex polygonal models with surprisingly few techniques.
- Starting from a primitive surface such as a cube, you extrude, split, scale, move, and rotate faces of the primitive to create a rough likeness of the object.
- You then adjust vertices to tune the shape, and finally smooth the edges between faces where desired.

Polygonal modeling has many timesaving features not covered in this lesson. For example, Boolean operations (union, intersection, and so on) are a common way to create a new object from the interaction of two existing objects.

If you’re planning to use your polygonal surfaces where the poly count is constrained, such as with computer games, Maya has a number of tools for minimizing the number of polygonal faces of
an object such as the Reduce Tool. Fewer faces means simpler geometry—This is critical when fewer polygons means increased interactive performance.

“Lesson 2: Sculpting a surface” on page 133 describes how to use the Sculpt Surfaces Tool. With this tool, you can drag your mouse to push, pull, and smooth a surface without first selecting vertices. Though that lesson shows how to shape a NURBS surface, you can apply most of the same techniques to polygonal surfaces with its polygonal counterpart, the Polygons > Sculpt Polygons Tool > 🔷.

If you want to learn more about a particular tool or feature that has been presented in this lesson, refer to the Maya Help.