Critical to learning any software program is some initial understanding of the basic concepts: how that software’s world works and the fundamental skills you need to work in that world. If you have never used a three dimensional (3D) software application before, you may initially find Maya different compared to 2D applications.

If you are wondering “where do I begin?”, this chapter is the best place to start. We recommend that you complete the lessons in this chapter so the essential concepts and skills presented become familiar to you.

This chapter covers some of the fundamental concepts and skills for Maya in four lessons:

- “Lesson 1: An overview of Maya’s user interface” on page 35
- “Lesson 2: Creating, manipulating, and viewing objects” on page 50
- “Lesson 3: Viewing the Maya 3D scene” on page 67
- “Lesson 4: Components and Attributes” on page 90
Preparing for the lessons
To ensure the lessons work as described:

- Ensure Maya is installed and licensed on your computer.
  
  If you have not installed Maya yet, refer to the *Installation and Licensing* manual that accompanies your Maya software package. It outlines the requirements for installing Maya and procedures for installation and licensing Maya on supported hardware platforms.
  
- If you have never started Maya on your computer before, it will start for the first time using the default preference settings.
  
- If you have run Maya before, you should ensure that your Maya user preferences are reset to their default setting. This ensures that the lessons appear and work as described.
  
Refer to Before you begin the lessons section in the Introduction of this book for instructions on resetting user preferences to the default setting.
Lesson 1  An overview of Maya’s user interface

Just as the driver of an automobile is familiar with the dashboard of their vehicle, it is important for you to become familiar with the Maya “dashboard.”

The Maya user interface refers to everything that the Maya user sees and operates within Maya. The menus, icons, scene views, windows, and panels comprise the user interface.

Through the Maya user interface you access the features and operate the tools and editors that allow you to create, animate, and render your three dimensional objects, scenes, and effects within Maya.

As you spend time learning and working with Maya, your knowledge of and familiarity with the user interface will increase until it becomes second nature.

In this lesson you learn how to:

- Start Maya on your computer.
- Use the Maya interface so that you can begin to understand where and how to access the critical tools to get started with Maya.
- Select the menu and icon sets within Maya.
- Learn the names of tools related to the icons in Maya.
- Create a new scene view.

This first lesson contains additional explanations of the tools and concepts compared to many of the lessons later in this manual. We suggest you take some time to review these explanations as they lay the foundation for understanding where things are in Maya.
Starting Maya

To start Maya on Windows

Do one of the following:

- Double-click the Maya icon on your desktop.
- (Windows 2000 Professional) From the Windows Start menu, select Programs > Alias > Maya 6.0 > Maya (Complete or Unlimited)
- (Windows XP Professional) From the Windows Start menu, select All Programs > Alias > Maya 6.0 > Maya (Complete or Unlimited)

To start Maya on Mac OS X

Do one of the following:

- Double-click the Maya icon on your desktop.
- Click the Maya icon in the Dock.
- From the Apple Finder menu, select Go > Applications and then browse for the Maya icon and double-click it to start Maya.

To start Maya on IRIX or Linux

Do one of the following:

- Double-click the Maya icon on your desktop.
- In a shell window, type: `maya`.

The Maya interface

Now that Maya is running, you first need to understand what you are seeing. There are a lot of items displayed in the Maya user interface.
The best way to begin is to learn the fundamental tools and then learn additional tools as you need them. Begin by learning some of the main tools.

The Maya workspace
The Maya workspace is where you conduct most of your work within Maya. The workspace is the central window where your objects and most editor panels appear.
When you start Maya for the first time, the workspace displays by default in a perspective window, or panel. There are the other components of the default perspective view panel:

- The panel is labeled \textit{persp} at the bottom to indicate that you are viewing the Maya scene from a perspective camera view.
- The panel has its own menu bar at the top left corner of the panel. These menus allow you to access tools and functions related to that specific panel.
- The grid is displayed with two heavy lines intersecting at the center of the Maya scene. This central location is called the \textit{origin}. The origin is the center of Maya’s 3D world, and with all object’s directional values measured from this location.
In Maya, like many other 3D applications, the three dimensions are labeled as the X, Y, and Z axes. The origin is located at X, Y, Z position of 0, 0, 0. The grid also lies along the X, Z plane. We refer to this as a plane because you might visualize an imaginary, flat, two-dimensional square laying along this 3D position.

Maya labels the X, Y, and Z axes with a color scheme: red for X, green for Y, and blue for Z. Many tools that you use in Maya use this color scheme to indicate that you are accessing a particular item that relates to X, Y, and Z in some way.

The axis indicator shows in which direction, X, Y, or Z, you are viewing the Maya scene. The axis indicator is color coded in the red, green, and blue color scheme and appears in the lower left corner of a view panel.
This is extremely useful if you are new to 3D, as many of the
instructions in this manual and the Maya Help assume you know
where you are viewing the scene in relation to the X, Y, Z axes.

**Main Menu Bar**

Tools and items are accessible from pull down menus located at
the top of the user interface. In Maya, menus are grouped into
*menu sets*. These menu sets are accessible from the Main Menu
Bar.

The Main Menu bar appears at the top of the Maya interface
directly below the Maya title bar and displays the chosen menu
set. Each menu set corresponds to a *module* within Maya:
Animation, Modeling, Dynamics, and Rendering. Modules are a
method for grouping related features and tools. (Maya Unlimited
has additional menu sets: Cloth, Fur, and Live.)

You switch between menu sets by choosing the appropriate
module from the menu selector on the Status Line (located
directly below the File and Edit menus). As you switch between
menu sets, the right-hand portion of the menus change, but the
left-hand portion remains the same; the left-hand menus are
common menus to all menu sets. The left-hand menus contain
File, Edit, Modify, Create, Display, and Window.
To select a specific menu set

1. On the Status line, select Animation from the drop-down menu.
   The Main Menu changes to display the menu set that relates to the Animation module. In particular, menu titles such as Animate, Deform, Skeleton, Skin, and so on, appear.

2. Using the menu selector, choose Modeling from the drop-down menu.
   The main menu changes to display the menu set for Modeling. Menu titles such as Edit Curves, Surfaces, Edit NURBS, and so on, appear.
   For now, leave the menu set at Modeling. You will use this set in the next step.

To create a primitive 3D object from the Modeling menu set

1. From the Main Menu Bar, select Create > Polygon Primitives > Cube.
   Maya creates a 3D cube primitive object and places it at the center (origin) of the Maya workspace.
Status Line

The Status Line, located directly below the Main Menu bar, contains a variety of items, most of which are used while modeling or working with objects within Maya. Many of the Status Line items are represented by a graphical icon. The icons save space in the Maya interface and allow for quick access to tools used most often.

In this lesson, you learn about some of the Status Line areas.

You’ve already learned the first item on the Status line: the Menu Selector used to select between menu sets.

The second group of circled icons relate to the scene and are used to create, open, and save your Maya scenes.

The third and fourth group of buttons are used to control how you can select objects and components of objects. You will learn more about selection of objects in later lessons.
The fifth group of icons are used to control the Snap Mode for objects and components. You will begin to use these tools in a later lesson in this chapter.

The last section comprise three buttons that are used to show or hide editors, including the Attribute Editor, Channel Box, Layer Editor, and Tool Settings. The default display shows the Channel Box and the Layer Editor. When you create an object, like the cube for example, information about that object displays in these editors. You will learn how to use these editors later in this chapter.

For better organization on the Status Line, all of the icon buttons are broken into groups that you can expand and collapse, as shown.

**Shelf**

The Shelf is located directly below the Status line. The Maya Shelf is useful for storing tools and items that you use frequently or have customized for your own use. You can keep the tools and
items you use most frequently in a location that provides handy access. Maya has some of the Shelf items pre-configured for your use.

To create an object using a tool from the Shelf

1. From the Shelf, select the Surfaces tab in order to view the tools located on that shelf.

2. From the shelf, select the NURBS sphere icon located on the left end of the shelf by clicking on it. Maya creates a sphere primitive object and places it at the center of the Maya workspace in the same position as the cube.
In your scene view the wireframe outline of the cube you created earlier in the lesson has changed color to navy blue, and the sphere is displayed in a bright green color. The sphere is now the selected object and the cube is no longer selected. In Maya, when the object displays like this, we refer to it as being selected or active.

Selection of objects and components is a way of indicating to Maya that this particular item is to be affected by the tool or action you will subsequently choose. As you work with Maya, you will be selecting and deselecting items a lot. You will learn how to select and deselect objects later in this chapter.
Some numerical information appears in the *Channel Box* editor on the right hand side of the user interface. This information relates to X, Y, and Z, translation, rotation, and scaling for the active object. The X, Y, and Z Translate numerical values are currently set to 0. This indicates that the sphere’s location is at the origin. The Channel Box is useful for viewing and editing this type of basic information. You will use the Channel Box later in this chapter.

To hide or show the Channel Box

1. To hide the Channel Box, click the Show/Hide Channel Box icon from the right end of the Status line.

   The Channel Box disappears, and the perspective scene view expands slightly. With the Channel Box hidden, you have more working area in your scene view.
2 To show the Channel Box, click the Show/Hide Channel Box icon on the Status line. The Channel Box appears in the scene view.

**Save your work**

Make it a habit to save your work often when working on your Maya projects. In that way, you can always open an earlier version of your work should you make a mistake.

Maya refers to everything you’ve created in your workspace as the *scene*. This includes any objects, lights, cameras and materials associated with your working session.

**To save your Maya scene**

1 Select File > Save Scene.
   
   A file browser appears, listing the default directory where you can save your scene.

2 Type: **Lesson1** in the file name text box.

3 Click Save.
   
   Maya saves your file to the scene directory within your Maya default project directory. Maya automatically saves the file with a `.mb` file extension. The `.mb` file extension indicates that the scene was saved as a Maya binary file: the default file type for a Maya scene.

**Exit Maya**

Before you exit Maya, ensure you save any work that you want to retrieve and continue with at a later time.

**To exit Maya**

1 Select File > Exit from the main menu.
   
   Maya does one of the two following actions:
If you have saved your scene immediately preceding the Exit command, Maya exits.

If you have not recently saved your scene, a message prompt appears on the screen asking if you want to save your changes. Click either Yes, No, or Cancel.

### Beyond the lesson

In this lesson you began your orientation to Maya by learning:

- How to start Maya on your computer.
- The Maya workspace, and how it shows three dimensional space (X, Y, Z).
- How Maya color-codes items and tools related to X, Y, Z.
- The location of the main menus for the various modules within Maya.
- How to create a three-dimensional object from the Modeling menu.
- The location of the Status Line and how items are displayed as icons.
- About the Shelf how to create a three dimensional object from the Shelf.
- How to hide and show the Channel Box and that basic transformation, scaling, and rotational information for an object can viewed in the Channel Box.
- How to save your work.
- How to exit Maya.
As you proceed through Getting Started with Maya you should be familiar with the fundamental concepts and skills covered in this first chapter.

If you want to learn more about a particular tool or feature that has been presented in this lesson, refer to the Maya Help.
Lesson 2  Creating, manipulating, and viewing objects

Using primitive objects to model 3D forms is a great place to continue learning about Maya. You can create many types of 3D objects using Maya and then move, scale, and rotate them to create more complex forms in your scene.

In this lesson, you begin to construct a classic temple using the primitive object creation tools in Maya. The project is not very complex and provides you with experience in using some of the important object manipulation and viewing tools.

As you continue to work with Maya, you’ll learn how to visualize more complex forms using these basic objects. Maya has many advanced tools and options for modeling complex forms, as you will learn in later chapters.

In this lesson, you learn how to:

- Create 3D primitive objects.
- Select objects for manipulation and editing purposes.
• Move and rotate objects using your mouse.
• Move, rotate, and scale objects using numeric input.
• Duplicate objects.
• Change the viewing panels in Maya using a variety of methods so you can view your objects from different points of view.
• Undo actions when you need to undo a particular task or step.

Creating a new scene

You begin your temple project by creating a new empty scene.

To create a new scene

1. Start Maya (if it is not already running).
   When Maya starts, it automatically creates a new scene.
   If Maya was previously running, follow steps 2 and 3.
2. From the main menu, select File > New Scene.
   Maya displays the following prompt.

   ![WARNING: Scene not saved.]

   `Save changes to untitled scene?`

   `Yes  No  Cancel`

3. Click No.
   Maya creates a new scene and delete everything that was in the previous scene.

Primitive Objects

Maya provides many types of primitive types and shapes such as cubes, spheres, cylinders, and planes.
Primitive objects can be used as a starting point for a wide variety of shapes and forms. The most common workflow when using primitive objects is:

- Set the construction options for the primitive when you initially create it so that it appears in the Maya scene roughly in the size and shape that you require.
- Move, scale, and rotate the primitive object into its final position either by direct manipulation (the move, scale, and rotate tools), or by entering numeric values through an editor.
- Duplicate the primitive objects to create multiple copies of the original or create different variations from your original primitive object.

In this section, you construct the base for the temple using a polygonal cylinder primitive. The octagonal shape is created by modifying the creation options for the cylinder tool before you create the object. If you did not modify the cylinder options you would create a round cylinder.

**To create a polygonal cylinder for the base**

1. Select the Modeling menu set.

   **Note**  
   Unless otherwise indicated, the directions in this lesson for making menu selections assume you’ve already selected the Modeling menu set.

2. From the main menu, select Create > Polygon Primitives > Cylinder > □.
An option window appears.

3 In the Polygon Cylinder Options window, select Edit > Reset settings and then set the following options:

- Radius: 10
- Height: 1
- Subdivisions Around Axis: 8
- Subdivisions Along Height: 1
- Subdivisions on Caps: 1
- Axis: Y

4 In the Polygon Cylinder Options window, click Create.
   Maya creates a cylinder primitive object that is octagonal in shape and positioned at the center of the Maya workspace. This cylinder is 20 units wide by one unit high, and has eight faceted sides.
Note: You were instructed to reset the option settings as a precaution in case they had been set differently. This is a good habit to practice when working with tool options to avoid getting a result that was different from what you expected.

**The Toolbox: Layout shortcuts**

The Tool Box is located on the left hand side of the Maya user interface. It contains icons that open tools for transforming your objects within Maya (selection, move, rotate, scale) as well as layout shortcuts for changing the views and panel layouts.

The Quick Layout buttons shortcuts allow you to select a different panel or switch to another layout.

You need to finish positioning the cylinder. To do this you need to see the object from a side view to make sure it is sitting exactly on the ground plane.
To change the panel layout to view the base from a side view

1. From the Toolbox, click the Four View layout shortcut.

The workspace changes to a four-view layout. The perspective view is located in the top right corner and the other views show the object from the top, front and side. The layout shortcuts have other options that you will learn later in this tutorial.
It is now possible to see the base from the side view, but it would be easier to determine the position of the base if the side view were enlarged to a full view.

2. To enlarge the side view, position the mouse cursor in the side view, and tap the spacebar of your keyboard.

The workspace changes to a single view layout with the side view in an enlarged view. It is easier to view the position of the base from this side view. Notice that the base lies slightly above and below the ground plane (X, Z).

| Tip | You can position your mouse cursor in any modeling view and click the spacebar once to toggle the view. If the view is a full panel view, it will change to a four panel view and vice versa. |

**The Tool Box: Transformation tools**

You need to move the base slightly upwards in the Y direction so it is positioned on the X, Z plane. To do this you use the Move transformation tool located in the Tool Box.

The upper half of the Tool Box contains the tools for transforming objects (selection, move, rotate, scale) within Maya. When you move your mouse cursor over any transformation tool icon you see the name of the tool appear next to the mouse cursor.
Selection and de-selection of objects

Before you can transform an object, you must ensure it is selected. You can select objects by clicking them directly, or by dragging a rectangular bounding box around some portion of the object to indicate what you want selected. To deselect an object, you simply click somewhere off of the selected object.
To select the base primitive object in the scene view

Do one of the following:

• With your left mouse button, click the object’s wireframe outline in the scene view.

• With your left mouse button, drag a bounding box around one corner or edge of the object’s wireframe.

The object is selected when its wireframe outline color displays in a bright green color. If it is not selected, its display color is navy blue.

To use the Move Tool to adjust the position of the base

1 Select the Move Tool from the Toolbox.

A move manipulator icon appears over the primitive cylinder in the scene view.

The Move Tool Manipulator has handles that point in the direction of the three fundamental axis directions of 3D space: X, Y, Z. The handles are colored red, green, and blue based on their function related to the X, Y, Z axes and control the direction of the movement along an axis.

When you click a specific handle, it indicates that the move is constrained to that particular axis direction.

2 In the side view, drag the green Y manipulator handle to move the primitive cylinder upwards in the Y direction. Move it upwards enough so that the bottom of the base cylinder is aligned with the X axis (the thick dark line of the grid).
The base cylinder now needs to be rotated slightly so the front of the base is parallel to a grid line. Since each facet of the octagon represents 45 degrees of a circle, you need to rotate the object approximately half of that amount or 22.5 degrees.

**To use the Rotate Tool to adjust the position of the base**

1. Display all four views by positioning the mouse cursor in the view and tapping the spacebar of your keyboard. The four view panel appears.

2. Position the mouse cursor in the top view and tap the spacebar once. The top view appears in the workspace.

3. With the base cylinder selected, choose the Rotate tool from the Tool Box. A rotate manipulator icon appears over the primitive cylinder in the scene view.

The Rotate Tool Manipulator consists of three rings (handles), plus a virtual sphere enclosed by the rings. The colors of the handles correspond to the X, Y, and Z axes. The handles are colored red, green, and blue based on their function related to the X, Y, Z axes and control the direction of the rotation around an axis.
4 In the top view, drag the green Y manipulator ring to rotate the primitive cylinder so that one of the facets of the base cylinder is aligned with the grid as shown in the image below.

You are rotating the cylinder around its Y axis.

You may be asking yourself the question “How do I know if I’ve rotated the base exactly 22.5 degrees?” You can check the accuracy of the rotation by viewing the Channel Box. Rotate Y should be close to 22.5 degrees.

Tip
You can undo and redo the last action you performed. Undo reverses the last action you performed on a selected object. It also reverses any action you performed from the Edit Menu.
To undo an action select, Edit > Undo. Maya allows you to perform multiple undos.

The Channel Box
The Channel Box is an editing panel that provides you access to an object’s transformation information and much more. It provides information on three distinct areas for any type of object: The transform node, shape node, and input node.

Nodes are where information about object types are kept track of within Maya. Nodes are comprised of attributes. Attributes refer to information related to what the node is designed to accomplish. In
this case, information about the primitive cylinder’s Y axis rotation is referred to as the Rotate Y attribute. You will learn more about nodes later in this tutorial.

When you moved and rotated the cylinder primitive using the Move Tool, you were doing this by your own visual judgement. This will usually be sufficient for many of your creative applications.

If you need to control the attribute of an object with more accuracy you can do this by entering the precise values into the appropriate attribute field of the Channel Box.

**To move and rotate the base using the Channel Box**

1. With the base cylinder selected, view the Transformation attributes in the Channel Box. Specifically, view the values for Translate Y, and Rotate Y.

   ![Channel Box](image)

   - **Translate Y**
   - **Rotate Y**

2. In the Channel Box, adjust the attribute values so they match the above image by clicking in the field and entering the correct numerical values.

   This accurately positions the base in your Maya scene.

   Maya named the cylinder primitive when it was first created. Rename the cylinder to something more meaningful to your project.
To rename the cylinder primitive using the Channel Box

1. In the Channel Box, click in the field with the name `pCylinder1`.

2. Rename the primitive object by typing the new name: `templeBase` and then pressing Enter.

Duplicating objects

Duplicating an existing object is a useful way to make an exact copy of it without having to start over. When you duplicate an item the copy takes on the characteristics of the original. Using the Duplicate Tool you can additionally apply transformations to the copy (move, rotate, scale).

Return to a four view layout to view what you’ve accomplished to this point.

To change the panel layout to a four view layout

- From the Toolbox, click the Four View layout shortcut.
  The workspace changes to a four view layout. It is easier to view the work from this four view layout.

  The base for the temple is constructed of two levels and appears stepped. You duplicate and scale the `templeBase` object using the duplicate tool.
To duplicate the temple base

1 Display all four views by positioning the mouse cursor in the view and tapping the spacebar. Then click in the perspective view to display the base in this view.

2 With templeBase selected, choose Edit > Duplicate > \[button\] from the main menu.

The Duplicate Options window appears.

3 In the Duplicate Options window, select Edit > Reset settings and then set the following options:
   - Translate: 0 1.0 0
   - Rotate: 0 0 0
   - Scale: 0.9 1.0 0.9
   - Geometry Type: Copy
   - Group under: Parent

4 In the Duplicate Options window, click Duplicate.

Maya creates a duplicate of the templeBase object that is scaled to 0.9 of the original in the X, Z axes, and is one unit above templeBase. As a result of the scale operation, the base for the temple now appears stepped.

Maya keeps track of the name of the duplicated object based on the name of original and renames the duplicated object templeBase1.
Creating a project

A project is a file directory that stores and organizes all of the files (scenes, images, materials, textures, etc.) related to a particular scene. In Maya, you create and work with a variety of file types and formats. The project directory allows you to keep these different file types in their unique subdirectory locations within the project directory.

To create a project

1. From the main menu, select File > Project > New. The New Project window opens.
2. Enter the name MayaBasics for the new project in the Name text box, and then click Use Defaults. Clicking Use Defaults will assign a default directory and name to the various subdirectories associated with the project.
3. Click Accept to create the new project with subdirectories. When you next save your work for this lesson it will automatically default to the MayaBasics project directory.

Save your work

In the last lesson we recommended that you save your work at regular intervals. An example of this is when you have just completed a major task such as constructing the base for the temple. With this strategy, if you ever make a mistake, you can always open the previously saved version of your work and begin from there.
To save your Maya scene

1. Select File > Save Scene. A file browser appears showing the default project scene directory where you can save your scene.
2. Type Lesson2Base in the file name text box.
3. Click Save.

Beyond the lesson

In this lesson you continued with the fundamental tools and skills to successfully learn:

- An overall workflow for constructing forms using primitive objects.
- Where the primitive object tools are located in the main menu.
- How to create a primitive object as well as reset and edit its creation options.
- How to change between a single view and four view panel layout using layout shortcuts and by tapping the spacebar of your keyboard.
- How to select objects by clicking them with your mouse.
- How to move and rotate objects using the transformation tools in the Tool Box.
- That tool manipulators can constrain a transformation to the X, Y, or Z axes.
- How to edit an object’s transformation node attributes (move, rotate, scale) accurately using the Channel Box.
- How to rename objects using the Channel Box.
- How to duplicate objects and apply transformations while doing so.
- How to create a project directory.
We suggest you additionally practice the following tasks on your own:

- Creating other primitive object types, with various options so that you can understand the variations that are possible.
- Practice moving, rotating, and scaling objects, and changing between the various scene views (single perspective, four view, single side, single top etc.)
Lesson 3  Viewing the Maya 3D scene

In the previous lesson you learned how to view your 3D scene by changing between single and four view layouts. It is important for you to learn how to change your views in a more interactive manner so that you can: view your objects close up or far away, select objects more accurately, or view objects from different angles in your perspective view.

In this lesson you learn how to:

- Understand the difference between moving objects in the scene and moving the point of view on the scene.
- Use the dolly, track, and tumble camera tools to change the view of your scene in both the orthographic and perspective views.
- Rotate objects using the transformation tools in the Tool Box.
- Select objects using a variety of techniques.
- Group objects together so they can be transformed as a unit.
- Display objects in both wireframe and shaded modes.
- Use additional primitive objects and options.
Camera Tools

In the lessons so far, when you looked at an object from the top, front, or side views you have been viewing the scene through an orthographic view. Orthographic views appear two-dimensional because the object is displayed using parallel projections of only two axes at a time. (Scooter images courtesy of The Art of Maya)

When you view the scene through the perspective view, you are viewing the scene in a three-dimensional manner. The perspective view simulates what your scene would look like from a camera’s point of view.
In Maya, you view the scene through a set of virtual cameras. These cameras are either orthographic or perspective in nature. You can adjust how these cameras view the scene using the Camera Tools.

The three primary methods for manipulating the camera view are *dolly*, *tumble*, and *track*.

**Dolly Tool**

The Dolly Tool gets its name from filmmaking where a camera, mounted on a wheeled tripod, is moved towards or away from the scene. In Maya, dollying allows you to view the items in your scene either close up or from further back.

---

**To dolly the perspective view**

1. Enlarge the scene view to a single perspective view.
2. Do one of the following:
   - (Windows) Press the Alt key and drag the mouse to the right while holding down the right button on your mouse.
   - (Mac OS X) Press the Option key and drag the mouse to the right while holding down the right button on your mouse.
   - (IRIX & Linux) Press the Alt key and drag the mouse to the right while holding down the left and middle buttons on your mouse.
3 To dolly the camera outwards from the subject in the scene you can perform the same key and mouse combinations as described above but drag the mouse to the left.

Dolly works in both the perspective and orthographic views.

Tip
If you make an error when adjusting your camera view of the scene, you can reset the camera to its default home setting.
To reset the camera view for a particular orthographic or perspective view:
From the panel menu, select View > Default Home.

Tumble Tool
The Tumble Tool allows you to tumble or rotate the camera’s view around a particular center of interest to achieve either a higher or lower vantage point, or a different side angle.
To tumble the perspective view

- Press the Alt key (Windows, IRIX, & Linux) or the Option key (Mac OS X) and drag the mouse either left or right, or up or down, while holding down the left button on your mouse. Tumbling the view revolves the camera around the center of the scene view, in whichever direction you drag (left, right, up or down). The Tumble Tool does not work in the orthographic views.

Track Tool

The Track Tool allows you to move the camera up, down, or sideways in relation to the scene.
To track the perspective view

- Press the Alt key (Windows, IRIX, & Linux) or the Option key (Mac OS X) and drag the mouse in any direction, while holding down the middle button on your mouse.
  
The Tracking Tool works for both orthographic and perspective views.

---

Note

Even though the objects appear to move across the screen when operating any of the camera tools, it is the viewing camera that is actually moved in relation to the scene, not the objects.
Workflow overview
The columns are made up of multiple primitives that are moved, scaled, and rotated into position. Once the first column is created, with each component named and accurately positioned, you will group and duplicate it to create others.

To create a polygonal cube for the pedestal
1. From the Main Menu, select Create > Polygon Primitives > Cube > □.
2. In the Polygon Cube Options window, select Edit > Reset settings and then set the following options:
   - Width: 1.75
   - Height: 0.6
   - Depth: 1.75
   Leave the other options at their default settings.
3. In the Polygon Cube Options window, click Create.
   Maya creates a cube primitive and positions it at the origin.
4. In the side view, move the cube upwards (Y axis) so it rests on the top surface of the temple base.
You can do this using the Move Tool or with the Channel Box. If you use the Channel Box, enter a Translate Y value of 2.3. You may find it useful to dolly or tumble the scene view to obtain a better viewpoint.

5 In the Channel Box, rename the cube *columnPedestal*.

**To create a polygonal cylinder for the shaft**

1 From the main menu, select Create > Polygon Primitives > Cylinder > □.

2 In the Polygon Cylinder Options window, select Edit > Reset settings and then set the following options:
   - Radius: 0.5
   - Height: 6
   - Subdivisions Around Axis: 12

Leaves the other options at their default settings

3 In the Polygon Cylinder Options window, click Create. Maya creates the cylinder primitive at the origin.

4 In side view, move the cylinder upwards (Y axis) so it rests on the top surface of columnPedestal. You can do this using the Move Tool or with the Channel Box. If you use the Channel Box, enter a Translate Y value of 5.6.
5 In the Channel Box, rename the cube `columnShaft`.

The capital for the column rests on top of the column and is very similar to the pedestal. You duplicate the pedestal and position the duplicate at the top of the column.

**To duplicate the pedestal to create the capital**

1 With only `columnPedestal` selected, select Edit > Duplicate > □ from the main menu.
   
The Duplicate Options window appears.
2 In the Duplicate Options window, select Edit > Reset settings and then set the following options:
   - Translate: 0 6.6 0
   - Scale: 0.8 1.0 0.8
   
   Leave the other options at their default settings.
3 In the Duplicate Options window, click Duplicate.
Maya creates a duplicate of the columnPedestal object and moves and scales it based on the options you set.

| Note | If you positioned the geometry for the column using the Transform Tools and your mouse, the Y translate values may be incorrect for your particular model. You may want to continue positioning the objects by visual reference using your mouse. |

Using the duplicate options is an alternate method for positioning and scaling duplicated objects when you can anticipate its final location.

4 In the Channel Box, rename the duplicated cube *columnCapital*.

The base for the column rests on top of the pedestal. You will create the base using one half of a NURBS sphere primitive and then move and rotate it into position. You will do this by modifying the creation options for the sphere primitive.

**To create a NURBS sphere for the column base**

1 Select Create > NURBS Primitives > Sphere > □.
2 In the NURBS Sphere Options window, select Edit > Reset settings and then set the following options:
• Start Sweep Angle: 0
• End Sweep Angle: 180
• Radius: 0.75
• Number of Sections: 8
• Number of Spans: 4
  Leave the other options at their default settings.
3 In the NURBS Sphere Options window, click Create.
  Maya creates a half-sphere primitive at the origin.

To rotate and position the sphere on the pedestal
The sphere needs to be rotated 90 degrees and then positioned on top of the pedestal.
1 In side view, rotate the sphere so that the dome part is pointing up.
  This is accomplished by either of the following methods:
  • Rotating the sphere about the X axis using the Rotate Tool’s manipulator handle.
  • Using the Channel Box to change the Rotate X value to -90.
2 Move the sphere so it rests on the top surface of columnPedestal (Translate Y = 2.6, if you have been inputting values into the Channel Box).
3 Using the Scale Tool, scale the sphere along its Z axis (blue manipulator handle) so that the sphere becomes slightly squashed in appearance.
When you scale an object non-uniformly along one of its axes, you are scaling it non-proportionally.

4 In the Channel Box, rename the sphere `columnBase`.

**Viewing objects in shaded mode**

Up to this point, you have been viewing your objects in the default wireframe mode. In wireframe mode, objects appear transparent except for the simple wire outline that indicates their position and general shape. Maya provides several options for displaying objects in a shaded manner.
Change the display of your scene so that the objects display as shaded objects.

**To display the objects in smooth shaded mode**

1. Enlarge your perspective view, and dolly and tumble the scene so you can easily view what you’ve completed so far.
2. From the panel menu, select Shading > Smooth Shade All.
   The objects in your scene display in an opaque dark gray color. You can work with objects in either shaded or unshaded mode for the balance of this lesson.

**Grouping objects**

When you need to move, scale or rotate multiple objects as one unit it is easier if they have been grouped together so that they transform as one unit.

Many of primitive objects in Maya are grouped objects. For example, the NURBS cube primitive is comprised of 6 flat squares or planes that have been grouped together as one unit. When the plane objects are grouped together they create a hierarchy.
A hierarchy is a collection of nodes or objects that are connected together to form a unit for some purpose. Hierarchies are useful for describing how the objects within them share similar characteristics or attributes; move, scale, rotate for example.

**To group the objects for the column**

1. Select the four objects that comprise the column simultaneously by doing one of the following:
   - With your left mouse button, shift-click each object in turn until the four objects are selected in the scene view.
   - With your left mouse button, drag one large bounding box around the column objects in an orthographic view.

   It is important that you do not select any of the templeBase objects as part of your selection. If you accidentally select any of the base objects, deselect them.

2. From the main menu, select **Edit > Group > */boxshadowup*.

3. In the **Group Options window**, select **Edit > Reset settings** and then set the following options:
   - **Group Under**: Parent

   Leave the other options at their default settings.

4. In the **Group Options window**, click **Group**.

   Maya groups the objects together in a hierarchy. You will learn more about hierarchies in the steps that follow.

**The Hypergraph**

The Hypergraph is a window that shows how the nodes and their connections are organized in your scene. You view object hierarchies and dependencies in the Hypergraph. Use the Hypergraph to view what happens when you group an object.
To view the Hypergraph

1. From the view menu, select Panels > Layouts > Two Panes Stacked.
   
   The scene view splits into two viewing panels - each has their own separate view menu. You will set these to view the scene in the upper view and the Hypergraph in the other.

2. From the lower pane menu, select Panels > Panel > Hypergraph.
   
   The Hypergraph panel will display below the scene view panel.

3. At the top of the Hypergraph panel, select the Scene Hierarchy icon.

4. In the Hypergraph panel, select View > Frame All.
   
   The Hypergraph displays the hierarchy for all of the objects in the scene. This approach to viewing the entities in the scene provides a very graphical approach to viewing all of the various nodes in your scene.
In the Hypergraph, each node is represented as a rectangle labelled with an icon that denotes the type of information it represents (for example, surface, shading, and so on). Each node has a unique name assigned to it when it is first created. When you rename your objects, you are actually renaming the node associated with that object.

Some nodes display with a line connecting them. This denotes that they are in a hierarchy and have a dependency structure based on how they were originally grouped.

For the temple’s column objects, the hierarchy displays each of the named objects under a node labelled `group1`. `Group1` is the parent node for this hierarchy of objects.

In Maya, when the parent node (sometimes referred to as the root node) is moved, rotated, or scaled in any way, the child nodes (sometimes referred to as the leaf nodes) underneath are also affected.

When you select objects at the top level of a hierarchy and move them, the objects within the hierarchy or group follow.

| Note | This system of nodes, attributes, and hierarchies may initially appear somewhat complex, but it is one of the most powerful features of Maya. The node based architecture provides flexibility and power to create complex models, shaders, and animations. |

**To rename the parent node in the Hypergraph**

1. In the Hypergraph, click on the `group1` node so it becomes active.

   In the scene view, all of the objects in the column group become selected as a result of selecting the group at the top (parent) level of the hierarchy.
2 In the Hypergraph, right-click the top node representing group1 and select Rename from the pop-up menu.
   A small text box appears in the node.
3 Enter Column as the new name.

Now that the column is grouped, you need to position it at one corner of the temple base.

**To position the column on the temple base**

1 Change the display of objects to wireframe mode by tapping the 4 key on your keyboard.
   This is a keyboard shortcut. Instead of selecting the item from the menu you can use a single key to implement the command.

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>Many of the tools and features in Maya can be accessed using keyboard shortcuts. In Maya, these shortcuts are called <em>Hotkeys</em>. Some Hotkeys are displayed directly beside the menu item, others are listed in the Hotkey editor. For a complete listing of available hotkeys, go to Window &gt; Settings/Preferences &gt; Hotkeys.</td>
</tr>
</tbody>
</table>

2 In the Hypergraph, select the Column at the top node so that Column becomes active in the scene view.
3 In the scene view, use the Move Tool to position Column at the front corner of the temple base as shown below.
With your first column in position, you can now create a copy of the column and position it on the adjacent corner of the base.

**To create a duplicate copy of the column**

1. With *Column* still selected in the Hypergraph, select Edit > Duplicate > □ from the main menu.
   The Duplicate Options window appears.
2. In the Duplicate Options window, select Edit > Reset settings and then set the following options:
   - Number of Copies: 1
   Leave the other options at their default settings.
3. In the Duplicate Options window, click Duplicate.
   The Hypergraph view updates to show an additional column object in the scene. The copy also takes on the prefix name of the original group and is now labelled *Column1*.

   In the scene view it appears that nothing was actually duplicated. When an object is duplicated without any transformations the copy is positioned in the same position as the original. The two objects are on top of each other.

You need to move the column into position on the adjacent corner of the temple base.
To move the duplicate column into position on the base

1. In the Hypergraph, ensure Column1 is selected by clicking on its top node so it becomes selected in the scene view.
2. In the scene view, use the Move Tool to position Column1 on the adjacent corner of the temple base as shown below.

3. From the Toolbox, click the Four View layout shortcut. The workspace changes to a four view layout and the Hypergraph is no longer displayed.

Selection Modes and Masks

It isn’t always efficient to have the Hypergraph window open when you want to select an object at a particular level within its hierarchy. Maya allows you to select items in different selection modes depending upon your specific needs.

There are three main types of selection modes: Hierarchy, Object and Component. You use these modes in order to mask or limit the selection of other objects in order to select only the types of items you want. When you use a selection mask you are filtering out or masking items you don’t want to be chosen as part of the selection.

The icons for the three modes appear on the Status Line.
When you first start Maya, the default selection mode is set to Objects. This is useful for much of your selection work with Maya, with a few exceptions. When you want to select items that have been grouped, set the selection mode to Hierarchy.

Tip
If you set the selection mask, it will remain that way until you change it again. If an item won’t select for you in Maya, you should check the selection mask setting to see if it is set correctly.

To use the Hierarchy selection mask

1. On the Status Line, choose the Select by Hierarchy and Combinations icon.
   The Selection Mask icons update to display the three selection choices.

2. On the Status Line, choose the Select by hierarchy icon.

   Select by hierarchy ensures that when you select items they are selected at their parent or root node.

3. In the scene view, shift-click Column and Column1 so they are selected simultaneously. (Do not be concerned that they highlight in different colors.)
Pivot points

A pivot point is a specific position in 3D space that is used as a reference for the transformations of objects. All objects (curves, surfaces, groups) have pivot points.

When you group objects in Maya, a new node called a parent node is created for the group of objects. The pivot point for the group’s parent node is placed at the origin (0, 0, 0). This is useful if you later want to duplicate and rotate the objects radially (that is, in a circular fashion around the pivot).

To group the two columns

1. Ensure Column and Column1 are selected.
2. From the main menu, select Edit > Group > .
3. In the Group Options window, select Edit > Reset settings. Set the following options:
   - Group Under: Parent
4. In the Group Options window, click Group.

   Maya groups the objects together in a hierarchy and the pivot point is positioned at the origin. (When the pivot point is relocated to the origin the Move Tool manipulator for the selected group appears at the origin)

With the two columns grouped, you then duplicate the columns with a rotation option, the groups will duplicate and rotate around the pivot point at the origin (0, 0, 0).

To duplicate and rotate the group

1. With column group selected, select Edit > Duplicate > from the main menu.
2 In the Duplicate Options window, select Edit > Reset settings and then set the following options:
   - Rotate: 0 90 0
   - Number of Copies: 3
3 In the Duplicate Options window, click Duplicate.
The columns are duplicated and rotated by 90 degrees with each copy.

Save your work
Your temple is taking shape! Save your work before proceeding to the next lesson.

To save your Maya scene
1 To save your Maya scene, select File > Save Scene As.
2 Type Lesson3Columns in the file browser area reserved for file names.
3 Click Save.

Beyond the lesson
In this lesson, you explored additional tools and skills within Maya as you continued with the construction of the classic temple. In this lesson you learned how to:
• Use your mouse to change the view of your scene using the dolly, track, and tumble camera tools in both the orthographic and perspective views.

• Rotate objects using the transformation tools in the Tool Box and the Channel Box.

• Group objects so they can be transformed as a unit.

• Display objects in both wireframe and shaded modes.

• Access the Hypergraph to view nodes and hierarchies. You are also learning that many tasks in Maya can be completed or approached using multiple techniques.

• Rename nodes within the Hypergraph.

• Select objects in your scene using the Hypergraph.

• Use the group pivot point to your advantage when duplicating objects.

Before proceeding with the next lesson you may want to review the material presented in this lesson so you are familiar with the concepts and skills associated with them. Some suggested tasks you can try on your own include:

• Practice using the view camera tools (dolly, track, and tumble) so you can navigate within the scene views efficiently.

• Practice moving and rotating objects, and changing between the various scene views (single perspective, four view, single side, single top, and so on).

• View objects in the Hypergraph so you can understand their relationships and hierarchy.
Lesson 4  Components and Attributes

Working with components is an important part of the workflow when working in Maya. Components describe objects at a more detailed level. As you edit the components of your classic temple, you will learn more about what is possible in Maya.

In this lesson you learn how to:

- Template objects in the scene.
- Understand the difference between objects and components.
- Edit objects at their component level.
- Assign surface material attributes
- Access the Attribute editor

Template Display

When your scene becomes complex, templating the display of some of the objects in your scene allows you to more easily select only the objects you want. When you template the display of an object, its wireframe changes to a gray color. The object(s) can still be seen, but not easily selected. This helps to prevent you from selecting or modifying it accidentally. You can change the display of objects to a template and use them as a modeling reference (the way a grid is used).

You need to change the display of the base and columns to template mode so that you can more easily work on the temple roof.

To template the base and columns

1  In the side view, with the Selection Mask set to Hierarchy, select all the objects in your scene.

2  From the main menu, select Display > Object Display > Template.
The selected objects become templated.

For your classic temple, you need to create the entablature using a torus primitive. An entablature is a structure that lies horizontally upon the columns of a temple and supports the roof.

**To create and position a torus primitive for the entablature**

1. From the main menu, select Create > NURBS Primitives > Torus.
2. In the NURBS Torus Options window, select Edit > Reset settings and then set the following options:
   - Radius: 8.5
   - Minor Radius: 0.5
   - Number of Sections: 24
3. In the NURBS Torus option window, click Create.
4. In the Channel Box, rename the torus primitive *Entablature*.
5. Move the entablature vertically in the scene so it rests on top of the columns (Translate Y = 9.7).
Components

All objects in Maya have a transform and a shape node. Geometric shapes, like the primitives in this tutorial, have smaller parts called components. A few examples of components in Maya are control vertices, faces and hulls. Components allow you to work with objects at a finer level and allow you to edit them in creative ways.

In order to change the shape of the entablature beyond the basic scale transformations, you need to modify its component information.

**To select components of the entablature**

1. In the side view, dolly in for a closer view of Entablature.
2. Set the Selection Mode to Components.
3. Right-click the wireframe of Entablature and select Control Vertex from the pop-up menu.
The menu that pops up is a marking menu for quickly selecting operations relevant to the object where you right-click the mouse. In this case, the choices pertain to the display of the entablature’s components.

A set of small blue squares appear on Entablature called control vertices. Control Vertices (CVs) describe the shape of an object based on their position in space. If you move any combination of these vertices, you change the shape of the object.

4 Drag a selection box around the top row of vertices so they become selected.

5 Using the Move Tool, move the vertices up vertically as shown below to change the shape of *Entablature*. 
To cancel the display of the CVs, right-click the wireframe of Entablature once again and select Object Mode from the pop-up menu.

The roof for the temple rests on top of the entablature. The roof for the temple is created using one half of a sphere primitive.

To create a roof for the temple
1  Select Create > NURBS Primitives > Sphere > □.
2  In the NURBS Sphere Options window, select Edit > Reset settings and then set the following options:
   •  Start Sweep Angle: 0
   •  End Sweep Angle: 180
   •  Radius: 8.75
   •  Number of Sections: 8
   •  Number of Spans: 4
   In the NURBS Sphere Options window, click Create.
3  Rename the half-sphere templeRoof.

The roof needs to be rotated 90 degrees and positioned on top of the entablature.

To rotate and position the roof on the entablature
1  In side view, rotate the roof so that the dome part is pointing up.
2  Move the roof so it is positioned close to the top edge of Entablature.
3  Scale the roof along its Z axis (blue manipulator handle) so that the sphere becomes slightly squashed in appearance.
Now that the roof is complete, you can untemplate the templated objects.

**To untemplate objects**

1. On the Status Line, choose the Select by Hierarchy and Combinations button.
2. On the Status Line, choose the Select by hierarchy: template button.
3. In the scene view, drag a selection box around all the objects in the scene so that the templated objects are selected simultaneously.
4. From the main menu, select Display > Object Display > Untemplate.
5. On the Status Line, choose the Select by hierarchy: root button.
The Attribute Editor

The Attribute Editor provides information about the various nodes and attributes for the objects and materials in your scene. Like the Channel Box, you can view and edit the basic transform information and many other keyable attributes. However, the Attribute Editor provides a more detailed display of all attributes for a selected object.

To view object attributes using the Attribute Editor

1. In the scene view, select templeRoof so it becomes the selected object.
2. To view the Attribute Editor, click the Show/Hide icon on the Status Line.

The Attribute Editor displays the attributes for templeRoof. The various attributes for the templeRoof object appear under various tabs. Each tab represents a node.
Click on the templeRoof tab to see its attributes.

This tab is known as the transform node, because the most important attributes on this tab control templeRoof’s transformation. Every visible object in Maya has a transform node, including cameras and lights.

Click on the templeRoofShape tab to see its attributes.

This tab is called the shape node because the attributes establish the object’s geometric shape or physical properties when the object is first created. Most objects have shape nodes, some do not, such as the group for the column objects. The shape node also includes other types of attributes, such as object display attributes.

Click on the makeNurbSphere tab to see its attributes.

This is an input node that includes attributes related to the object’s construction history. The attributes of an input node are passed to another node subsequent in the construction history for the object—in this case, to the templeRoofShape node.

The last two nodes are initialShadingGroup and lambert1. If you can’t see them, click the display arrow.

The initialShadingGroup and lambert1 nodes are default nodes that relate to the default shading material for an object. Maya uses them to establish the initial color of objects and other settings related to shading. If you create your own shading materials for the temple, as you will in the following steps, these nodes are replaced by the new shading nodes you create.
Surface Materials

The color, shininess, and reflectivity attributes of an object are controlled by its surface material (sometimes referred to as a shader, or shading material). Material attributes relate to how the object simulates a natural reaction to light in Maya’s 3D computer world.

Maya assigns a default shading material to all objects when they are first created. In this section, you learn how to assign a new material to your objects.

To assign a new material to the temple objects

1. Right-click the wireframe of Entablature and select Object Mode from the pop-up menu.

This changes the selection mask back to objects so you can select objects in the scene. It is a shortcut to access this feature.

2. Drag a selection box around all the objects in your scene to select them.

Tip

If objects won’t select in the Maya scene, check that your selection mask is set correctly on the Status Line.
3 From the Status Line, select the Rendering menu set using the menu selector.
   The main menu changes to display the menu set for Rendering.

4 From the main menu, select Lighting/Shading > Assign New Material > Blinn.
   A Blinn shading material is assigned to all the objects in the scene and the Attribute Editor updates. Blinn shading materials (named after the inventor of this shading algorithm) provide for high-quality specular highlights on surfaces.

5 In the Attribute Editor, rename the blinn1 shading material to templeShader.

With a shading material assigned to all the objects, you need to edit the color attributes of the templeShader material.

**To edit the shading material’s attributes**

1 In the Attribute Editor, click in the gray box to the right of the word Color.

![Color Chooser](image)

The Color Chooser appears.
2 Click inside the color wheel (hexagon) and drag the pointer to achieve a sand color.

The exact color is unimportant for this lesson. As you adjust the color wheel indicator, the temple objects become the same color you select in the Chooser.

3 Click Accept to close the chooser.

You will learn more about Maya’s shading and texturing capabilities in future lessons.
4 In the Attribute Editor menu, choose the Selected menu item, and select templeBase from the list.

The attributes for templeBase display in the Attribute Editor.

5 Click on the templeShader node tab to see its attributes.

If you can’t see this tab, click the display arrow to the right of the tabs.

These are the same attributes you edited when you assigned the templeShader shader to all the objects in the scene. When you first create an object, you see two default nodes for shading, initialShadingGroup and lambert1. When you assign a shading material, the two default nodes are replaced by the attribute node for the assigned shading material.

You will encounter transform, shape, input, and shading nodes throughout your work with Maya. There are other types of nodes that you’ll learn about as you continue learning about Maya.

6 Close the Attribute Editor using the Show/Hide icon.

**Save your work**

You have completed this lesson. Save your work before proceeding.

**To save your Maya scene**

1 Select File > Save Scene As.

2 Type Lesson4Final in the file browser area reserved for file names, and then click Save.
Beyond the lesson

In this lesson, you completed the construction of the classic temple and learned how to:

- Display objects in template mode.
- Select objects at their component level using selection masks and the right mouse button.
- Assign and edit shading materials for your objects in the scene.
- Access the Attribute editor and view the various node types for objects.

As you proceed through Getting Started with Maya, we assume you are familiar with the fundamental concepts and skills covered in this first chapter.

Before proceeding to the next chapter you may want to review the material presented in this lesson so you are familiar with the concepts and skills associated with them. Some suggested tasks you may want to do on your own:

- Practice construction of additional forms using primitive shapes by creating additional details for your temple scene (stairs, roof details, etc.).
- Learn more about the tools and options that have been presented in this lesson, by referring to the Maya Help. To view the Maya Help, select Help > Maya Help.