1 Introduction

Welcome to Maya, the world’s leading software application for 3D digital animation and visual effects. Maya provides a comprehensive suite of tools for your 3D content creation work ranging from modeling, animation, and dynamics through to painting and rendering to name but a few.

With Maya, you can create and edit 3D models in a variety of modeling formats and animate your models using Maya’s suite of animation tools. You can create convincing visual simulations of rigid and soft body objects interacting in the physical world using the computational dynamics and particles tools. Maya also provides a range of tools to allow you to render your animated 3D scenes to achieve photo realistic imagery and animated visual effects.

The Maya software interface is fully customizable for those users who require the ability to maximize their productivity. Maya allows users to extend their functionality within Maya by providing access to MEL (Maya Embedded Language). With MEL, you can customize the user interface and write scripts and macros. In addition, a full Application Programmers Interface (API) is available to enhance the power and functionality of Maya.

The content creation power of Maya is provided to users in an integrated software application that is designed to enhance user productivity and ease of use.

The goal of this manual is to assist you in getting started with Maya as you embark upon your learning path.

This chapter provides the following information:

• About Getting Started with Maya–Contents of the Getting Started with Maya manual.
1 | Introduction
> About the Getting Started tutorials

- Prerequisites—What you should know before using Getting Started with Maya.
- Installing Maya—Information on installing Maya.
- Using the Getting Started with Maya files—How to copy the files provided on CD-ROM for the Getting Started with Maya lessons.
- Maya Help—Outlines the help resources provided with your Maya software.
- Additional Resources—Outlines resources beyond what is included with your Maya software.

About the Getting Started tutorials

*Getting Started with Maya* introduces the different areas of Maya in a set of brief tutorials. The tutorials are designed to let you learn these modules at your own pace.

If you are new to Maya, this manual gets you started on your learning path. If you are an existing user or are transitioning from another 3D software application, *Getting Started with Maya* provides a starting point for understanding features you haven’t yet had time to learn.

If you are a user of *Maya Unlimited* you can learn about the features of your software by going through the lessons in *Getting Started with Maya Unlimited* which accompanies your software package. If you are new to Maya, we recommend that you begin with the tutorials contained within Getting Started with Maya.

*Getting Started with Maya* is not meant to replace the documentation that comes with the Maya software. Only the commands and options used in the lessons are explained in this manual. You will find the Maya Help provides an excellent companion reference to the lessons and much more.
Many of the tutorials in *Getting Started with Maya* contain one or more separate lessons that provide step-by-step instructions for creating or accomplishing specific tasks within Maya. You can follow the tutorials in this book from start to finish or complete only the tutorials that correspond to your interests and needs.

We recommend that any new Maya user begin by completing the following:

- Viewing the Essential Skills Movies that are available when you first start Maya.
- Completing the Maya Basics tutorial (Chapter 2) which introduces many fundamental concepts and skills related to the Maya user interface.

Getting Started with Maya is also available for use within the Maya Help. This version of Getting Started with Maya contains QuickTime movies for some of the lessons that supplement the printed version of the manual.

The Maya Help version of Getting Started with Maya includes two additional lesson chapters that are not available in the printed version of this manual. The two additional lesson chapters are: *Expressions* and *MEL*. Any data files required for these lessons are included with the *Maya Documentation, Lessons, and Extras CD*.

**To use the tutorials from the Maya Help**

1. In Maya, select Help > Tutorials.
   - The Maya Help window displays the *Getting Started with Maya* tutorials.

2. Click the tutorial you want to work through.
   - The Maya Help displays the associated lessons for that tutorial.
Before you begin the Getting Started tutorials

Before beginning Getting Started with Maya, you should have a working knowledge of your computer’s operating system. You should know how to use a mouse, select menus, and enter text and commands from your keyboard. You should also know how to open and save files, copy files from a CD-ROM to your hard drive, and be able to navigate your computer operating system’s file browser.

If you require an overview or review of these techniques, we recommend that you refer to the documentation that came with your particular computer and operating system.

If you are new to 3D computer graphics and animation, you may want to obtain *The Art of Maya* (ISBN: 1-894893-45-X, available from the Alias online store). It explains many concepts and techniques that are unique to the world of 3D computer graphics as they relate to Maya.

Installing Maya

You must have Maya installed and licensed on your computer system to successfully complete the lessons in this manual. To operate Maya on your computer you must be running a qualified Windows, Mac OS X, IRIX, or Linux operating system with the recommended minimum memory and storage requirements. Maya requires a three button mouse to access its full functionality for menus, commands, and 3D viewing.

For complete instructions on qualified hardware and operating systems, as well as installation and licensing of the Maya software, please refer to the *Installation and Licensing* manual that came with your Maya software or see the Support section of our Web site at www.alias.com.
Conventions used in this book
Some important conventions used throughout Getting Started with Maya are explained here.

Maya is available for use on a wide range of operating systems. Any differences between operating systems when operating Maya are identified in the following ways:

(Windows), (Mac OS X), (IRIX), (Linux)

The screen illustrations and examples within Getting Started with Maya vary among the Windows, Mac OS X, IRIX, and Linux operating systems. Maya’s interface is generally consistent across these systems.

When instructed to select a menu within Maya we use the following convention:

• Menu > Command (For example, File > New Scene)

![Menu Options]

When you are instructed to select the option box for a particular menu item within Maya, we use the following convention:

• Menu > Command > Option (For example, Create > NURBS > Primitives > Sphere > □).
1 Introduction
> Using the Getting Started lesson files

Using the Getting Started lesson files

Some of the Getting Started with Maya lessons have accompanying Maya files that were created for use with the lessons. These files are contained on the Maya Documentation, Lessons, and Extras CD-ROM which is included with your Maya software package. To use the lesson files, do one of the following:

- Open the Getting Started with Maya lesson files directly from the Maya Documentation, Lessons, and Extras CD-ROM.
- Copy the Getting Started with Maya lesson files to your computer’s hard drive and then open them from your hard drive.

To open the lesson files from your CD-ROM drive

1 Insert the Maya Documentation, Lessons, and Extras CD-ROM into your drive.
2 Within Maya, select File > Open Scene.
3 Navigate to the CD-ROM drive, locate the Getting Started with Maya folder, and select it.
4 Double-click on the Getting Started with Maya lessons folder to view its contents.
5 Double-click the specific lesson and tutorial file to open it in Maya.

To copy the lesson files from the Maya Documentation, Lessons, and Extras CD-ROM

1 Insert the Maya Documentation, Lessons, and Extras CD-ROM into your drive.
2 From the CD-ROM, copy the Getting Started with Maya folder to your computer into the following directory:
   (Windows) drive:\Documents and Settings\username\My Documents\maya\projects

Getting Started with Maya
22
1 | Introduction

> Maya Help

(Mac OS X) Users/username/Documents/maya/projects
(IRIX & Linux) ~username/maya/projects

When you are asked to open specific lesson files, open the Getting Started with Maya lessons that you have copied to the projects directory.

**Maya Help**

Your Maya software application comes with a comprehensive set of documentation resources.

**Essential Skills Movies**

The first time you start Maya, the Essential skills movies window displays in Maya. Watch these movies to learn about the skills you need to master when you first use Maya.
To play the Essential Skills Movies

1. In the Essential Skills Movies window, click the buttons to play the movie.
   Your computer launches its default multimedia player and your chosen movie begins to play.
2. Click your multimedia player’s controls to start, stop, and pause the movie.
3. To view the online help of your multimedia player, select its help menu.

To close the Essential Skills Movies window or the multimedia player

1. To close the Essential Skills Movies window, click the close box in the upper right corner of the window.
   If you do not want to have this dialog box automatically display when you start Maya, turn on the Don’t show this at startup check box.
2. To close the multimedia player, select File > Exit or click the close box in the upper right corner of the window. (This instruction may vary depending upon which multimedia player is used)

If you want to watch the movies in the future

- In Maya, select Help > Learning Movies.
  The Essential Skills Movie window appears.

Maya Help

Your Maya software application comes installed with Maya technical documentation that assists you in learning the Maya software. The Maya Help is HTML-based, structured by module, fully searchable, and is displayed using your computer’s web browser.
The Maya Help is topic based and displays the major functionality categories for Maya. The Maya Help can assist you in finding reference information about particular topics, how to perform specific tasks, and MEL command references.

**To launch the Maya Help**

- Select Help > Maya Help.
  
  The Maya Help appears in a separate browser (depending on your user preference settings).

**To obtain help on a particular Maya topic**

- In the Maya Help window, click the name of the Maya topic you want information about (for example, Animation, Dynamics, MEL commands, etc.).
  
  The Maya Help displays the associated sub-topics and categories associated with the name you selected.

**Maya Index and search**

You can search the Maya Help directly using the index and search capabilities. With these tools you find the Maya topic you’re looking for by searching the topic word in an alphabetic list or by directly typing the topic word(s) into the search field and having the search tool find the documentation entries associated with it.

**To use the Maya Index**

1. In Maya, select Help > Maya Help.
   
   The Maya index appears near the top of the Help window as an alphabetic set of icons.

2. To view an index entry by alphabetic listing, click the letter icon that is associated with the first letter of your desired topic (for example: Click on D for Dynamics).
The Maya index displays all entries in the Maya Help that begin with the letter D in the left navigation pane.

3 Scroll through the alphabetic listing until you find the entry you are looking for using the scroll bar on the right side of the pane.

4 In the left navigation pane, click the entry you want.
   The information related to that topic appears in the right pane.

**To use the Maya Search**

1 Select Help > Maya Help.
   The Maya Help appears in a separate window (depending on your user preferences). You search for your topic by typing in a specific word that best represents the information you require.

2 In the Search text box at the top of the Maya Help window, type a word that best represents your search topic.

3 Click the magnifying glass icon to begin your search.
   The search results appear in the left navigation pane, sorted by relevancy.

4 Click the appropriate search result in the left window.
   The information related to that entry appears in the right window. By default, the search will find both topic related information as well as task based and related tutorials.

**Popup Help**

Popup Help provides you with a quick method of identifying a particular tool or icon in the Maya user interface.
To use Popup Help

- Move your mouse cursor over an icon or button. The name or description of it appears in a popup window directly over it.

To enable Popup Help if it does not appear

1. Select Help.
   The Help menu appears.
2. If a check mark is displayed beside the word Popup it indicates that the Popup Help is enabled. If a check mark is not displayed beside the word Popup, follow the next step:
3. In the Help menu, select Popup.
   The next time you access the Help menu, a check mark appears beside the Popup menu item, indicating that Popup Help is enabled.

Help Line

The Help Line at the bottom of Maya’s window shows information about tools, menus, and objects. Like the Popup help, it displays descriptions when you move the mouse over icons and menu items. It also displays instructions when you select a tool. This is useful if you don’t know or forget how to use a particular tool.
To use the Help Line

- Move your mouse cursor over an icon or button. The icon or button name and instructions about how to use that tool appear in the Help Line.

Find Menu

The Find Menu allows you to find the location of a particular menu. Find Menu works only on the main menu items.

To find the location of a main menu item

1. Select Help > Find Menu. The Find Menu window appears.
2. Type the menu item you want to locate in the text field, and press Enter (Windows, IRIX, and Linux), Return (Mac OS X).
The possible locations for the main menu display in the results field of the Find Menu window.

**Maya Quick Reference**

*Maya Quick Reference* is a printed reference that came with your Maya software package. It contains keyboard shortcut information that you will want to keep handy for quick reference.

**Additional learning resources**

Beyond the Maya help resources within your Maya software, you can access the following resources to learn more about Maya or obtain technical assistance.

**The Alias Web site**

The Alias Web site contains a wealth of resources related to your Maya software and related products and services.

You can view the Alias Web site by selecting Help > Alias on the Web in Maya or by entering [www.alias.com](http://www.alias.com) in your web browser.

**Alias Education**

Alias provides a range of products and services to help you get the most from your Maya software. You can purchase additional self-study learning materials or attend certified instructor led training courses at our Alias training facilities. Alias also runs Maya seminars at major computing trade shows and events. For more information, select the Education link on the Alias web site.

**Alias Support**

Alias Support delivers technical support services globally through telephone and email Hotline services, as well as online eSupport services. For more information, click the Maya Support Center link from the Maya Help menu or click the Support link on the Alias web site.
Restoring default user settings

If you have already used Maya or have a prior version of Maya installed, you should restore the default settings for Maya before you begin the lessons. This ensures that Maya appears and operates exactly as the lessons describe.

If you are an existing user of Maya we recommend that you save your existing preferences for later use prior to restoring the default user settings.

To save your existing custom user preferences

1. Ensure Maya is not running.
   Each time you exit Maya it saves the configuration of most components of your user interface so it appears the same when you start it the next time. It writes the preferences to a directory called `prefs`. If you rename the `prefs` directory, your original preferences will be maintained and Maya will create a new `prefs` directory the next time it is run.

2. Rename your existing user preferences file to a name, for example, `myprefs`. The `prefs` directory path is:
   - (Windows) `\Documents and Settings\username\My Documents\maya\6.0\prefs`
   - (Mac OS X) `Users/username/Library/Preferences/Alias/maya/6.0/prefs`
   - (IRIX & Linux) `~username/maya/6.0/prefs`
   If you have a previous version of Maya installed, also rename that `prefs` directory to a new name such as `myprefs`. Maya will load older preferences if they exist from a previous version.

3. Start Maya and begin the Getting Started with Maya lessons.
To restore your custom user preferences after doing the lessons

1. Ensure Maya is not running.
2. Rename the previously changed preferences back to `prefs`. 
1 | Introduction
  > Restoring default user settings